vCenter Server Convergence activity stuck at 8% due to invalid update repository configuration
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vCenter Server Convergence activity stuck at 8% due to invalid update repository configuration

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Article ID: 338250

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • VCSA 6.7 External PSC Convergence process stuck at 8%
  • The convergence process starts successfully but makes no progress after 8% for a long time
  • In /var/log/vmware/converge/converge_status.json, you will find entries similar to:

{
    "description": "Converge vCenter with external PSC to embedded PSC",
    "end_time": "",
    "id": "",
    "message": "Getting RPMs.",
    "msg_id": "15",
    "progress": 8,
    "start_time": "2019-04-12 14:28:08",
    "status": "RUNNING",
    "subtask": [
        {
            "key": "precheck",
            "value": {
                "description": "Precheck validations for converge",
                "status": "SUCCEEDED"
            }
        },
        {
            "key": "requirements",
            "value": {
                "description": "Gather requirements",
               
"status": "RUNNING"
            }
        },
  • The process is stuck at Gather requirements stage.
  • In /var/log/vmware/converge/converge.log, you see the below information:
 
2019-04-12T19:28:08.757Z INFO converge Downloading RPMs
2019-04-12T19:28:08.757Z INFO converge Collected client:rest as a part of Telemetry
2019-04-12T19:28:08.834Z INFO converge Custom URL repositry not configured.Use default VMware repository URL.
2019-04-12T19:28:08.834Z INFO converge  currentURL = https://vapp-updates.vmware.com/vai-catalog/valm/vmw/8d167796-34d5-4899-be0a-6daade4005a3/6.5.0.5100.latest/
2019-04-12T19:28:08.834Z INFO converge Manifest file = https://vapp-updates.vmware.com/vai-catalog/valm/vmw/8d167796-34d5-4899-be0a-6daade4005a3/6.5.0.5100.latest/manifest/manifest-latest.xml


Environment

VMware vCenter Server Appliance 6.7.x

Cause

The vCSA repository is pointing to a vCSA 6.5 repository, which is suppose to point to 6.7
 

Resolution

To resolve this, you need to point the vCSA to a vCSA 6.7 repository.
  • Download ISO of current version of vCenter Server from VMware Downloads.
  • Mount the ISO to vCenter Server Virtual Machine
  • Modify the Update repository.
    • Log into the VAMI page (https://vcsa_fqdn:5480).
    • Under the Update tab > Click on Check Updates and click on the CD/DVD ISO for picking up the repository.
6.7 U2:
https://vapp-updates.vmware.com/vai-catalog/valm/vmw/8d167796-34d5-4899-be0a-6daade4005a3/6.7.0.30000.latest/ 

6.7 U3:
https://vapp-updates.vmware.com/vai-catalog/valm/vmw/8d167796-34d5-4899-be0a-6daade4005a3/6.7.0.40000.latest/ 

6.7 U3b:
https://vapp-updates.vmware.com/vai-catalog/valm/vmw/8d167796-34d5-4899-be0a-6daade4005a3/6.7.0.42000.latest/ 
  • Take a snapshot of the vCSA.
  • Take a putty session to the vCSA , run command to delete files from previous convergence attempt
# rm -rf /root/velma/*
# rm -rf /storage/log/vmware/converge/*
  • Restart the vCenter Server to terminate the hung Convergence process 
  • Run the convergence process again.


Additional Information

VMware Skyline Health Diagnostics for vSphere - FAQ