Configuring HA on the cluster fails with the error: No space left on device
search cancel

Configuring HA on the cluster fails with the error: No space left on device

book

Article ID: 338110

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Configuring HA on the cluster fails with the error:
Cannot install the vCenter server agent service. Unknown installer error
  • Installation of the FDM agent fails
  • Unable to remove the host from vCenter server
  • Unable to disable HA on the cluster: An error occurred while communicating with the remote host
  • In the /var/log/fdm-installer.log or /var/log/syslog.log, you see entries similar to:
<YYYY-MM-DD>T<time> fdm-installer: [13452413] </time><YYYY-MM-DD>T<time></time>: Logging to /var/run/log/fdm-installer.log
<YYYY-MM-DD>T<time> fdm-installer: [13452413] </time><YYYY-MM-DD>T<time></time>: extracting vpx-upgrade-installer/VMware-fdm-eesx-2-linux-2442329.tar.gz...
<YYYY-MM-DD>T<time> fdm-installer: [13452413] </time><YYYY-MM-DD>T<time></time>: Installing the VIB
<YYYY-MM-DD>T<time> smbiosDump: would have tried to popen /sbin/udevadm info -e 2>/dev/null</time>
<YYYY-MM-DD>T<time> smbiosDump: would have tried to popen /usr/bin/udevinfo -e 2>/dev/null</time>
<YYYY-MM-DD>T<time> fdm-installer: [13452413] </time><YYYY-MM-DD>T<time></time>: Result of esxcli software vib install -v=/tmp/vmware-root/ha-agentmgr/vpx-upgrade-installer/vmware-fdm.vib: [InstallationError]
<YYYY-MM-DD>T<time> fdm-installer: [Errno 28] No space left on device</time>
<YYYY-MM-DD>T<time> fdm-installer: vibs = VMware_bootbank_vmware-fdm_5.5.0-2442329</time>
<YYYY-MM-DD>T<time> fdm-installer: Please refer to the log file for more details.</time>
<YYYY-MM-DD>T<time> fdm-installer: [13452413] </time><YYYY-MM-DD>T<time></time>: All done! Status: 0
<YYYY-MM-DD>T<time> sfcb-vmware_raw[35512]: IpmiIfcRhFruInv: Reading FRU header for 0xd FAILED cc=0xc3</time>
<YYYY-MM-DD>T<time> crond[33622]: crond: USER root pid 13453179 cmd /sbin/hostd-probe ++group=host/vim/vmvisor/hostd-probe</time>



Environment

VMware vCenter Server Appliance 5.5.x

Cause

This issue occurs due to insufficient space in the /tmp folder.

Resolution

To resolve this issue, create sufficient space in the /tmp folder.

To create sufficient space in the /tmp folder:

  1. Open a console to the ESX/ESXi host. 
  2. Determine the free disk space on each filesystem using vdf -h command. For more information, see Investigating disk space on an ESX or ESXi host (1003564).
  3. Free up space on the /tmp folder.
  4. Restart the Managements agents on the host.
  5. Disable and reconfigure HA on the cluster.



Additional Information