Site Recovery Manager is not shown as a licensed asset in the vCenter Server Appliance even after manual registration or modify installation
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Site Recovery Manager is not shown as a licensed asset in the vCenter Server Appliance even after manual registration or modify installation

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Article ID: 338077

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Updated On:

Products

VMware Live Recovery VMware vCenter Server

Issue/Introduction

  • After installing Site Recovery Manager (SRM), the asset fails to show as a licensed entity in vCenter Server Appliance.
  • The license for SRM is added to the vCenter Server Appliance and displays the expiration date, but is not able to be assigned to any solution.

  • In the /var/log/vmware/vpxd.log file, you see entries similar to:
<YYYY-MM-DD>T<time> [7FC605CB9700 error 'linuxvpxLdap_linux' opID=402657c0] [LDAP Client] Failed to add LDAP entry cn=,ou=Licenses,ou=Licensing,dc=virtualcenter,dc=vmware,dc=int: 0x34 (</time>
Invalid DN syntax)
<YYYY-MM-DD>T<time></time> [7FC605CB9700 error 'linuxvpxLdap_linux' opID=402657c0] [LDAP Client] LdapApi::add_s: key (cn)
<YYYY-MM-DD>T<time></time> [7FC605CB9700 error 'linuxvpxLdap_linux' opID=402657c0] [LDAP Client] LdapApi::add_s: key (objectClass)
<YYYY-MM-DD>T<time></time> [7FC605CB9700 error 'linuxvpxLdap_linux' opID=402657c0] [LDAP Client] LdapApi::add_s: key (vmw-vc-LicenseTotal)
<YYYY-MM-DD>T<time></time> [7FC605CB9700 error 'linuxvpxLdap_linux' opID=402657c0] [LDAP Client] LdapApi::add_s: key (vmw-vc-LicenseName)
  • In the /var/log/ldapmessages log file on vCenter Server Appliance, you see entries similar to:
<YYYY-MM-DD>T<time></time> BBSR0066 slapd[14576]: send_ldap_result: err=21 matched text="vmw-vc-LicenseEntityName: value #0 invalid per syntax"
<YYYY-MM-DD>T<time></time> BBSR0066 slapd[14576]: send_ldap_response: msgid=320 tag=105 err=21
<YYYY-MM-DD>T<time></time> BBSR0066 slapd[14576]: conn=1002 op=319 RESULT tag=105 err=21 text=vmw-vc-LicenseEntityName: value #0 invalid per syntax

Cause

This issue is caused by special characters in the Site Recovery Manager site name entered during installation. The following characters are known to cause the issue, however, it is not limited to these characters.
  • ü
  • ç
  • ãê

Resolution

Reinstall Site Recovery Manager using a site name that does not include special characters.