Deleting SAM configuration in VMware Telco Cloud Operations does not clear associated Notifications/Topology
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Deleting SAM configuration in VMware Telco Cloud Operations does not clear associated Notifications/Topology

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Article ID: 337600

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Updated On:

Products

VMware VMware Telco Cloud Operations

Issue/Introduction

Symptoms:
After deleting SAM configuration from Smarts Integration under Administration, some Notifications and Topology might be dangling when seen in Operation UI even after several minutes post deletion of SAM config in VMware Telco Cloud Operations.

Perform the steps listed below to identify if the issues exists in your environment:
1. Navigate to Operations > Notification Log view 
2. Edit log view
3. Add “Notification Source” attribute
4. Filter by name of deleted SAM against “Notification Source”
5. If Notifications exists in Log view, then this issue exists in your environment


Environment

VMware Telco Cloud Operations 1.x

Cause

This issue typically occurs under high load where Ingestion or dependent services such as Redis/Elasticsearch might have thrown errors under extreme load conditions.

Resolution

This is a known issue and currently there is no resolution.

To workaround this issue, retry Clean-up by performing resync against deleted SAM. using steps below:
 
1. Perform resync of notification/topology by adding SAM (Administration > Smarts Integration)  that was deleted using Smarts Integration.
2. Once SAM is added, resync would be performed which will resync notifications and Topology from SAM.
3. Wait for Resync to be completed.
4. Delete SAM using Smarts Integration.
 
Note: Retry procedure should not be done immediately after deletion is performed.