Cleaning up decommissioned SRM registration from vCenter Server
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Cleaning up decommissioned SRM registration from vCenter Server

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Article ID: 337576

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Updated On:

Products

VMware Live Recovery VMware Site Recovery Manager 8.x

Issue/Introduction

  • Clicking SRM or vLSR sites in the vSphere Web Client fails with the following error:
    Failed to connect to Site Recovery Manager Server at https://<SRMIP>:9086/vcdr/vmomi/sdk. Reason: java.net.ConnectException: Connection refused (Connection refused)
  • The error occurs for an SRM/vLSR server that is no longer used but was previously registered to the vCenter Server.
  • The working SRM/vLSR pair continues to work.

Environment

  • VMware Site Recovery Manager 8.x
  • VMware Live Site Recovery 8.x
  • VMware Live Site Recovery 9.x

Cause

This issue occurs if SRM/vLSR leaves behind stale registrations from the de-commissioning process.

Resolution

SRM/VRMS MOB Extension cCleanup

  1. Navigate to http://<vCenter_Server_name_or_IP>/mob.
    Where <vCenter_Server_name_or_IP> is the name of your vCenter Server or its IP address.

  2. Click Content > ExtensionManager.


  3. Click the More tab to see the complete list of extensions registered to the vCenter Server.


  4. Note the number of extensions for com.vmware.vcDr.

    Note: In a stale registration, you may see multiple registrations. For example, com.vmware.vcDr and com.vmware.vcDr-dr1.

  5. Click each extension and click Server.

    Note: On the next page, you will see the IP address of the SRM server that is tied to that extension.

  6. Validate which one is stale and copy the extension ID.

  7. Go to ExtensionManager and click UnregisterExtension.


  8. Copy the extension ID into the string value and click the Invoke method. You see a void result message.


  9. Refresh the page and ensure the extension no longer shows up.

Registered SRM Solution User Check

  1. Log in to the vCenter Server with the SSO account.

  2. Click Administration - User and Groups > Solution Users.

    Note: Ensure that there are only two solution users for a single paired site.

  3. Check the certificate end date for the solution user and remove the one with the old date. You can also validate the stale solution user from the
    owner ID captured in step #13.

  4. In some cases, you may continue to see the error about a stale SRM IP. You must check the SRM service registrations by running this command on the PSC:
    • If the vCenter Server is version 6.x:
      /usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk --no-check-cert --ep-type com.vmware.dr.vcDr 2>/dev/null
    • If the vCenter Server is version 7.x / 8.x:
      cd /usr/lib/vmware-lookupsvc/tools/
      ./lstool.py list --url http://localhost:7090/lookupservice/sdk --no-check-cert --ep-type com.vmware.dr.vcDr 2>/dev/null
  5. Copy and paste the output to a text editor and search for the SRM registration. For example:
    Name: vCenter DR service (vCenter-dr)
    Service Product: com.vmware.dr 
    Service Type: vcDr 
    Service ID: ########-####-####-####-######
    Site ID: default-first-site
    Node ID: ########-####-####-####-############ 
    Owner ID: SRM-########-####-####-####-############@domain.local Version: #.#.# Endpoints:
    Type: com.vmware.dr.vcDr Protocol: 
    vmomi URL: https://##.##.##.###:9086/vcdr/vmomi/sdk
  6. Using the IP address in the vmomiURL, you can confirm which SRM registration is stale.

    Note: The IP address in the vmomiURL is the IP address of the SRM server.

  7. Take a snapshot of the vCenter Server and PSC before performing the below steps. If the PSC is in linked mode, a powered-off snapshot of all PSCs is recommended.

  8. Use the service ID of the stale registration and run this command to unregister it from the PSC:
    • If the vCenter Server is version 6.x:
      /usr/lib/vmidentity/tools/scripts/lstool.py unregister --url http://localhost:7080/lookupservice/sdk --id Service_ID_stale_SRM --user '[email protected]' --password 'administrator_password' --no-check-cert
    • If the vCenter Server is version 7.x / 8.x:
      cd /usr/lib/vmware-lookupsvc/tools/
      ./lstool.py unregister --url http://localhost:7090/lookupservice/sdk --id Service_ID_stale_SRM --user '[email protected]' --password 'administrator_password' --no-check-cert

      Note: Replace the user name and password as per the SSO user name and password.

Additional Information