Cleaning up decommissioned SRM registration from vCenter Server
search cancel

Cleaning up decommissioned SRM registration from vCenter Server

book

Article ID: 337576

calendar_today

Updated On:

Products

VMware Live Recovery VMware Site Recovery Manager 8.x

Issue/Introduction

Symptoms:

  • Clicking SRM or vLSR sites in vSphere Web Client fails with the error:

    Failed to connect to Site Recovery Manager Server at https://SRMIP:9086/vcdr/vmomi/sdk. Reason: java.net.ConnectException: Connection refused (Connection refused)
     
  • The error is for the SRM/vLSR server which is no longer used and earlier registered to vCenter Server.
  • The working SRM/vLSR pair continues to work.



Environment

VMware Site Recovery Manager 8.x

VMware Live Site Recovery 8.x

VMware Live Site Recovery 9.x

Cause

This issue occurs if SRM/vLSR is leaves behind stale registrations from the de-commissioning process

Resolution

To resolve this issue:

  1. For SRM/VRMS MOB extension cleanup follow below steps.
    • Navigate to http://vCenter_Server_name_or_IP/mob.

      Where, vCenter_Server_name_or_IP/mob is the name of your vCenter Server or its IP address.
       
    • Click Content > ExtensionManager.
             

    • Click the More tab to see the complete list of extensions registered to the vCenter Server.



    • Note the number of extensions for com.vmware.vcDr.

      Note: In stale registration you may see multiple registration. For example, com.vmware.vcDr and  com.vmware.vcDr-dr1.
       
    • Click each extension and click Server.

      Note: In the next page you will see the IP address of SRM server which is tied to that extension.
       
    • Validate the which one is stale and copy the extension id.
    • Go to ExtensionManager and click UnregisterExtension.

    • Copy the extension ID in the string value and click the Invoke method.
      You see a void message



    • Refresh the page and ensure the extension no longer shows up.

2. Registered SRM Solution User  

    • Login to the vCenter Server with the SSO account.
    • Click Administration-User and Groups > Solution Users.

      Note: Ensure that there only two solution users for a single paired site.
       
    • Check the certificate end for solution user date and remove the one with old. You can also validate the stale solution user from the owner ID caputred in step #13.
    • In some cases, you may continue to see the error about stale SRM IP. You must check the SRM service registrations by running this command on PSC.



3. If vCenter server is version 6.x:

/usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk --no-check-cert --ep-type com.vmware.dr.vcDr 2>/dev/null

4. If vCenter server is version 7.x:

        /usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk --no-check-cert --ep-type com.vmware.dr.vcDr 2>/dev/null

    • Copy and paste the output to a notepad and search the SRM registration.

      For example:

      Name: vCenter DR service (vCenter-dr)
      Service Product: com.vmware.dr 
      Service Type: vcDr 
      Service ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxx
      Site ID: default-first-site
      Node ID: ########-####-####-####-############ 
      Owner ID: SRM-########-####-####-####-############@domain.local Version: x.x.x Endpoints:
      Type: com.vmware.dr.vcDr Protocol: 
      vmomi URL: https://xx.xx.xx.xxx:9086/vcdr/vmomi/sdk 

       
    • Using the IP address in the vmomiURL you can confirm which SRM registration is stale.
      Note: IP address in the vmomiURL is the IP address of the SRM server
       
    • Take a snapshot of vCenter Server and PSC before performing the below steps. If the PSC is in linked mode, powered off snapshot of all PSC is recommended.
    • Use the service ID of the stale registration and run this command to unregister it from the PSC:

       5. If vCenter server is version 6.x:

   /usr/lib/vmidentity/tools/scripts/lstool.py unregister --url http://localhost:7080/lookupservice/sdk --id Service_ID_stale_SRM --user '[email protected]' --password 'administrator_password' --no-check-cert

      6. If vCenter server is version 7.x:

      /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url http://localhost:7090/lookupservice/sdk --id Service_ID_stale_SRM --user '[email protected]' --password 'administrator_password' --no-check-cert

       Note: Replace the user name and password as per the SSO user name and password.



Additional Information