vCenter displays vRealize Operations version 6.7 instead of the current installed version
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vCenter displays vRealize Operations version 6.7 instead of the current installed version

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Article ID: 337507

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article describes how to correct an outdated VMware vRealize Operations version on the vCenter Interoperability page.

Symptoms:
  • The vCenter Interoperability page lists vRealize Operations as 6.7.000000 instead of reporting the current version of vRealize Operations.


Cause

The problem is caused by a VMware vRealize Operations configuration file containing an older version string.
This issue is cosmetic only.

Resolution

To resolve this issue, complete the steps below.
  1. Log into the vRealize Operations UI with the local admin user.
  2. Navigate to Administration > Solutions > Cloud Accounts.
  3. Edit the Cloud Account for the vCenter adapter instance (Cloud Account) for your vCenter in question.
  4. Make note of the Collector / Group node that the Cloud Account is connected to, this will be needed later.
  5. Click Manage Registrations.
  6. Enter vCenter Credentials (User Name / Password) that allow changing vCenter plugin registrations or select Use Collection Credentials (if the existing collection credentials allow changing vCenter plugin registrations).
  7. Click Unregister.
  • Optional: Repeat steps 3-7 for any other vCenter adapters.
  1. Log into the vRealize Operations Manager Admin UI as the local admin user.
  2. Click Take Offline under Cluster Status.
Note: Wait for Cluster Status to show as Offline.
  1. Log into the node noted in step 4 as root via SSH or Console, pressing ALT+F1 in a Console to log in.
  2. Open /usr/lib/vmware-vcops/user/conf/configuration.properties in a text editor.
  3. Change productVersion=6.7.0 to productVersion=current_version.
  4. Note: Replace current_version with the current vRealize Operations version.
  5. ExampleproductVersion=8.2.0
  6. Save and close the file.
  • Optional: It is recommended to repeat steps 10-15 on all other nodes in the vRealize Operations cluster to avoid this issue happening for other vCenter adapters added later.
  1. Log into the vRealize Operations Manager Admin UI as the local admin user.
  2. Click Bring Online under Cluster Status.
Note: Wait for Cluster Status to show as Online.
  1. Log into the vRealize Operations UI as the local admin user.
  2. Navigate to Administration > Solutions > Cloud Accounts.
  3. Edit the Cloud Account for the vCenter adapter instance (Cloud Account) for your vCenter in question.
  4. Click Manage Registrations.
  5. Enter vCenter Credentials (User Name / Password) that allow changing vCenter plugin registrations or select Use Collection Credentials (if the existing collection credentials allow changing vCenter plugin registrations).
  6. Click Register.
  • Optional: Repeat steps 20-23 for any other vCenter adapters.
The vCenter Interoperability page will now report the entered vRealize Operations version.