IP customization failing for Windows guests with VMware Tools version 12.2.5
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IP customization failing for Windows guests with VMware Tools version 12.2.5

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Article ID: 337398

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:


Following VMWare Tools upgrade from version 12.2.0 to version 12.2.5 on Windows VMs, the Site Recovery Manager IP customization process fails. The error displayed in the Recovery Plan report is "Failed to authenticate with the guest operating system using the supplied credentials".


Environment

VMware Site Recovery Manager 8.x

Cause


Inside the guest operating system, "C:\Program Files\VMware\VMware Tools\VMware VGAuth\VGAuth.dll" is missing after VMWare Tools upgrade from version 12.2.0 to version 12.2.5. This issue does not happen when VMware Tools is upgraded to version 12.2.5 from versions prior to 12.2.0, nor a fresh install of 12.2.5.

Resolution


This issue is resolved in VMware Tools 12.2.6. If you have an affected Windows VM, upgrading from VMware Tools 12.2.5 to 12.2.6 will replace the missing VGAuth.dll file. Please refer to the Download link and Release Notes link below for more information.

VMware Tools 12.2.6 Download
VMware Tools 12.2.6 Release Notes

Workaround:
The recommended fix to this issue is to upgrade from VMware Tools 12.2.5 to 12.2.6 however if you would prefer to workaround this issue on 12.2.5 there are two options below.

Note: The following workarounds do not require a reboot of the guest operating system and will not cause any interruption.

Option 1: On a per VM basis

Run the following PowerShell command as Admin inside each affected VM:

msiexec /qn /i (Get-WmiObject -Class Win32_Product | Where-Object {$_.Name  -eq 'VMware Tools'}).LocalPackage

Option 2: Bulk VM basis

Note: For this method to work, each ESXi hosts ProductLocker needs to be updated with the VMware Tools 12.2.5 package. See Installing and upgrading the latest version of VMware Tools on existing hosts (2129825)

Identify a Windows machine to use VMware PowerCLI and RDP to it, this can be an administrators local system or a jumpbox which has access to the target vCenter using FQDN or IP.

1. Open Windows PowerShell terminal. Note: Admin terminal is not required.

2. Install VMware PowerCLI if not done so before.

  2.1 To check VMware PowerCLI version currently installed, run:

Get-Module -Name VMware.PowerCLI -ListAvailable

  2.2 To install VMware PowerCLI, run:

Install-Module -Name VMware.PowerCLI -Scope CurrentUser

      This installs the latest version VMware PowerCLI to the current user directory $home\Documents\PowerShell\Modules.

3. Run this command before running any script:

Set-ExecutionPolicy -Scope CurrentUser RemoteSigned

4. Run this command to set Prompt if the server certificate is not trusted:

Set-PowerCLIConfiguration -Scope Session -InvalidCertificateAction Prompt

5. Run this command to establish a connection to the vCenter server:

Connect-VIServer -Server '<VC server name>' -User '[email protected]' -Password 'password'

   Verify and accept the server certificate.

6. To fix an individual VM run:

$vm = Get-View -ViewType VirtualMachine -Filter @{"Name"="<VM_NAME>"}

then

$vm.UpgradeTools($NULL)

To fix ALL powered-on Windows VMs with VMware Tools version 12.2.5 (12357), run:

$vms = Get-View -ViewType VirtualMachine -Filter @{"Guest.ToolsRunningStatus"="guestToolsRunning";"Guest.GuestFamily"="windowsGuest";"Guest.ToolsVersion"="12357"}

then

$vms | ForEach-Object {'Working on VM ' + $_.Name; $_.UpgradeTools_Task($NULL); Sleep 3}
 

Note: If the following error is received in the vCenter task "Initiated VMware Tools install or upgrade" when you initiate the commands in "Option 2" then the ESXi host ProductLocker has not been updated to include VMware Tools 12.2.5 files.

Error upgrading VMware Tools. vix error code = 21009

7. Run this command to close the connection to the vCenter server:

Disconnect-VIServer -Server $DefaultVIServer -Force -confirm:$False