OVF deployment fails with the error: "task was canceled by a user"
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OVF deployment fails with the error: "task was canceled by a user"

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Article ID: 337376

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Deploying OVF template from a vSphere datastore fails.
  • In the vSphere Web Client, you see this message:

    OVF deployment failed: SHA1 digest of file .vmdk does not match manifest

  • Under the tasks for Deploy OVF template, the status reports:

    The task was canceled by a user

Cause

This issue occurs because when uploading a VMDK file from your computer to vSphere storage using the datastore browser, the MD5 checksum changes. Therefore, the checksum in the SHA1 digest does not match.
Note: When you Deploy OVF Template from your computer, the MD5 does not change and no error is reported.

Reports indicate that "task was canceled by a user" may have other causes, such as using Internet Explorer instead of Chrome. See also KB 2117310.

Steps to duplicate

  1. Select a VM and Export OVF Template to your computer running vSphere Web Client.
  2. Create a new folder and upload the .mf, .ovf, and VMDK files. For more information, see Upload Files to Datastores.
  3. Browse to https://ESXi.host/folder.
  4. Log in and navigate to the new folder in its datastore.
  5. Copy the link address of the OVF file.
  6. In the vSphere Web Client, click Deploy OVF Template and provide the link address as the source URL.
  7. Enter the required values in the wizard and click Finish.


Resolution

As a workaround, use one of these options:

  • Copy the exported OVF files directly to the ESXi datastore using WinSCP or equivalent.
    Note: Ensure that SSH is initially enabled on the ESXi host.
  • Remove or do not upload the *.mf manifest file.
    Without the SHA checksum in the manifest, vSphere allows the OVF template to be imported, and the resulting VM will deploy.

Additional Information

For translated versions of this article, see: