The Manager UI fails to load vCenter service connection information
search cancel

The Manager UI fails to load vCenter service connection information

book

Article ID: 337220

calendar_today

Updated On:

Products

VMware Integrated OpenStack

Issue/Introduction


When attempting to load vCenter connection information in the manager web interface, the end-user will be met with a spinning loading symbol instead.

Environment

7.x

Cause

Users will experience this when there are duplicate VIOShim and VIOUtils services in the custom resource for the deployment. This commonly happens after upgrading.

Resolution

To fix this perform the following steps:

  1. SSH into the VMware Integrated OpenStack Lifecycle Manager as root.
  2. To open the custom resource for the deployment type: osctl edit osdeployment
  3. Under the configuration for separate spec items and before status in the file we will find duplicate VIOShim and VIOUtils settings. Delete them until there is only one.
  4. Save and exit the file.
  5. Wait a few minutes for the configuration to complete, and check back within the manager web interface to confirm the fix.



Additional Information