The Manager UI fails to load information
search cancel

The Manager UI fails to load information

book

Article ID: 337220

calendar_today

Updated On:

Products

VMware Integrated OpenStack

Issue/Introduction

  • When attempting to load vCenter connection information in the manager web interface, the end-user will be met with a spinning loading symbol instead
  • Spinning wheel on services tab in Web UI
  • No data is shown
  • The osdeployment CR has duplicate entries for vioutils or vioshim
    ...
        - conf: Octavia:octavia1
          name: octavia1
          service: octavia
        - conf: VIOShim:vioadmin1
          name: vioadmin1
          service: vioshim
        - conf: VIOUtils:vioutils1
          name: vioutils1
          service: vioutils
        - conf: VIOShim:vioadmin1
          name: vioadmin1
          service: vioshim
        - conf: VIOUtils:vioutils1
          name: vioutils1
          service: vioutils
      status:

Environment

7.x

Cause

Users will experience this when there are duplicate VIOShim and VIOUtils services in the custom resource for the deployment. This commonly happens after upgrading.

Resolution

To fix this perform the following steps:

  1. SSH into the VMware Integrated OpenStack Manager as root.
  2. To open the custom resource for the deployment type:
    osctl edit osdeployment
  3. Go to the end of spec: and right above status:
  4. Look for duplicate entries of VIOUtils: and/or VIOShim: and remove the duplicates.
  5. Save and Exit.
  6. Wait a few minutes for the configuration to complete, and check back within the manager web interface to confirm the fix.



Additional Information