Missing MQ Metrics with Reason Code 2033

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Article ID: 33705

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Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

Issue:

  Customer's MQ Metrics are grayed out in the Investigator.  In the MQ Agent.log we found an ERROR with a Reason Code 2033.  After research we found

  that on the customers Queue Manager's Command Server was not functioning.  The customer restarted the Command Server and recycled the agents and

  all the metrics were available again.

 

Environment:

  IBM Websphere MQ and APM EM version 9.5.2 (This KB should be true for all versions of APM)

 

Cause:

  [ERROR] [com.wily.powerpack.websphereMQ.agent.MQMonitor.TracerDriverThread] MQMonitor: For configuration instance PAMQFLD001 and the

  drivers(namelist,cluster) an error occured in sending query to MQ. The target MQ (pamqfld001.thrivent.com:5102) may be down.  Reason code 2033

  MQRC_NO_MSG_AVAILABLE - for the logs.

 

  This error is telling you that the agent can't communicate with Queue Manager.  

 

  Here is key information from the APM for IBM WebSphere MQ Guide about the Command Server:

 

Verify Server Connection and Access

  To ensure proper server connection, verify the following:

  ?  A WebSphere MQ command server that is defined and running on the Queue Manager.

  ?  A Server Connection channel that is defined on the Queue Manager.

      Note: Contact your WebSphere MQ specialist for details about configuring the Queue Manager.

 

  ?  Network access through firewalls, for the MQ Monitor Agent. 

 

Resolution:

  Work with the MQ Administrator to make sure the Command Server is running correctly.  

Environment

Release:
Component: APMINT