VMware vRealize Automation intermittently reports the IAAS error: The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement
search cancel

VMware vRealize Automation intermittently reports the IAAS error: The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement

book

Article ID: 336924

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • In VMware vRealize Automation the IAAS server is reporting the error:

    The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement

    <innerexception i:nil="true"><Message>The wait operation timed out</Message><stacktrace i:nil="true"><Type>System.ComponentModel.Win32Exception</Type></InnerException><Message>Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time. The duration spent while attempting to connect to this server was - [Pre-Login] initialization=21045; handshake=0; </Message><StackTrace> at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)</stacktrace></innerexception>


  • The error is seen intermittently and a service restart resolves the issue.


Environment

VMware vRealize Automation 6.2.x

Cause

This issue occurs when VMware vRealize Automation IaaS server is trying to use IPv6 while the SQL server is only accepting IPv4 packets.

Resolution

To resolve this issue, disable IPv6 on the VMware vRealize Automation IaaS servers, or enable IPv6 for the SQL server