Proxy Agent fails to communicate with IaaS manager service in vRealize Automation 6.2.x
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Proxy Agent fails to communicate with IaaS manager service in vRealize Automation 6.2.x

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Article ID: 336919

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Proxy Agent fails to communicate with Manager Service through Load Balancer address.
  • Manager service is down on both active and passive nodes.
  • In vRealize Automation logs, you see entries similar to:

    Exception occurred when retrieving work from VRM: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.


Environment

VMware vRealize Automation 6.2.x

Cause

This issue occurs when proxy agent fails to startup. If a proxy agent fails to startup due to unavailability of some dependent services, it fails to recover even after dependent services becomes available.

Resolution

This is a known issue affecting vRealize Automation 6.2.x.
To work around, restart the vSphere Proxy Agent.

To restart the vSphere Proxy Agent:
  1. Log in to Proxy agent server.
  2. Navigate to Start > Administrative Tools > Services
  3. Restart the vRealize Automation Agent – agent_name service.