Logging into NSX-T UI shows "Some appliance components are not functioning properly. Error code: 101"
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Logging into NSX-T UI shows "Some appliance components are not functioning properly. Error code: 101"

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Article ID: 336790

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Updated On:

Products

VMware NSX

Issue/Introduction

•  Logging into NSX-T UI shows "Some appliance components are not functioning properly.  Error code: 101" and the URL will show nsxmanager_FQDN/appliance-not-healthy.html#

•  In a 3 node NSX-T Manager cluster, 2 of the 3 manager nodes may not startup properly.  For example the affected 2 may boot up on Emergency Mode

• The 3 Manager nodes seem to be failing at startup with UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY

• The 3 Manager nodes when booted may seem stuck in a Linux startup process, i.e. (iniramfs)

• In /var/log/syslog, there are 2 of the NSX-T Manager IPs showing a similar timeout:
 

YYYY-MM-DDTHH:MM:SS.SSSZ NSXMGR1.FQDN.lab NSX 1738 - - Tried to get layout from <NSX Manager IP Address>:9000 but failed by timeout
 



Environment

VMware NSX-T Data Center
VMware NSX

Cause

This issue may have been caused by an outage that affected the NSX-T Manager nodes, such as a power or storage outage. In a three Manager node environment, if two out of the three nodes are lost or encounter operational issues during boot up, the NSX-T UI will report that some components are not functioning properly. When the majority of the cluster is down, the UI will be inaccessible.

Resolution

If you encounter this error, please contact Broadcom Technical Support for assistance.

See Creating and managing Broadcom support cases for details on opening a case.