Logging into NSX UI shows "Some appliance components are not functioning properly. Error code: 101"
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Logging into NSX UI shows "Some appliance components are not functioning properly. Error code: 101"

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Article ID: 336790

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Logging into the NSX UI shows
    Some appliance components are not functioning properly.  Error code: 101

  • The URL within the browser may show
    <nsxmanager_FQDN>/appliance-not-healthy.html#
  •  In a 3 node NSX Manager cluster, 1 or 2 of the manager nodes may not startup properly.  For example the affected node may boot up in Emergency Mode
  • Manager nodes may show to be failing at startup with message shown in the console
    UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY
  • Manager nodes when booting may seem stuck in a Linux startup process, i.e. (iniramfs)

  • In /var/log/syslog, there are 2 of the NSX Manager IPs showing a similar timeout:
    YYYY-MM-DDTHH:MM:SS.SSSZ NSXMGR1.FQDN.lab NSX 1738 - - Tried to get layout from <NSX Manager IP Address>:9000 but failed by timeout

Environment

VMware NSX-T Data Center
VMware NSX

Cause

This issue may have been caused by an underlying outage that affected the NSX Manager nodes, such as a power or storage outage. In a three Manager node environment, if two out of the three nodes are lost or encounter operational issues during boot up, the NSX-T UI will report that some components are not functioning properly. When the majority of the cluster is down, the UI will be inaccessible.

This may also be caused by underlying performance issues with the ESXi hosts where the NSX managers reside on or with datastore performance issues that the NSX managers are using. 

Resolution

If you encounter this error, please contact Broadcom Technical Support for assistance.

See Creating and managing Broadcom support cases for details on opening a case.