Editing roles in vRA Identity & Access Management fails with: “An error occurred. Please try again later…”
search cancel

Editing roles in vRA Identity & Access Management fails with: “An error occurred. Please try again later…”

book

Article ID: 336725

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Assigning permissions to a group or user via Identity & Access Management is resulting in an error:

An error occurred. Please try again later…

  • Developer Tools in your browser shows that PATCH request returns the following error message:

<html>
<head>
<title>Request Rejected</title>
</head>
<body>The requested URL was rejected. Please consult with your
administrator.<br><br>Your support ID is:
<%TS.request.ID()%></body>
</html>


Environment

VMware vRealize Automation 8.x

Cause

This issue is caused due to F5 BIG-IP ASM (Application Security Manager) configuration blocking the PATCH method.

Resolution

To resolve the issue, add PATCH as allowed method in your F5 BIG-IP ASM.

For more information, consult F5 documentation.