Best practices for handling notification messages in stdlog and activity log
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Best practices for handling notification messages in stdlog and activity log

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Article ID: 33653

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Warning messages appear in the NX_ROOT/logs/STDLOG log files after attempting to send Notifications from CA Service Desk Manager. 

STDLOG Message “No notification method”

[EXAMPLE SDM SERVER]  spelsrvr             3660 SIGNIFICANT  cnt.spl               1147 AHD05376: The '[SAMPLE CONTACT] 'contact did not receive a notification - no notification method specified for level Normal.

 

SDM Ticket Notification History and Activity Log:

AHD05341:Warning! This contact did not receive a notification - no notification method specified for level Normal.

AHD05376:The '[SAMPLE CONTACT] ' contact did not receive a notification

 

STDLOG Message “Email address is not set.”

[EXAMPLE SDM SERVER]  bpnotify_nxd         5760 ERROR        pdm_mail_common.c     1346 Email address is not set. Email Subject(Incident XXXX Adjust Impact Urgency) Message(AHD05341: Warning!  This contact did not receive a notification - no notification method specified for level Normal.  Message: Incident XXXX Adjust Impact Urgency. Assigned to: [SAMPLE CONTACT] Customer: [SAMPLE CONTACT]  

 

SDM Ticket Notification History and Activity Log:

AHD05377:No email address specified for Contact  '[SAMPLE CONTACT] '

Environment

CA Service Desk Manager 14.x  and higher

All Supported Operating Systems

Cause

These messages occur when specific conditions for sending the Notification are not met.

Message “No notification method”

A Notification Method has not been specified against the recipient’s Contact Record.  Valid values are:

  • Email
  • Notification
  • Pager_Email
  • SMS
  • or any other configured Notification Method

 A value of "<Empty>" will trigger the STDLOG message.

 

STDLOG Message "Email address is not set."

The Contact record is missing an email address.

Resolution

Use any of the following methods to help minimize or avoid these STDLOG messages/errors.

It is recommended that you work your way through the list from top to bottom, in terms of benefit.

These methods are not mutually exclusive, but act together.

  • Methods (1) to (3) are to correct data at the source

  • Method (4) prevents log messages from writing

 

Method #1 – Populate valid notification data

Both messages may be prevented by completing the notification data that is missing.  Review your system to confirm that all CA SDM contacts who are expected to receive Notifications have the appropriate setup.

Tips:

  • It is recommended that notification data is populated when creating the Contact record, where possible

  • It may help to periodically report against the above fields, to identify missing/incorrect data

  • Minor changes may be corrected through the client interface. Mass changes may be better handled by other means, such as a SQL command to populate all Notification Methods with defaults. The latter lies outside of scope for Support to provide assistance

 

Method #2 – Avoid notifications to Contacts without valid data

These messages are only triggered when a Notification is called against a CA SDM contact without the required data.  Avoiding sending notifications to CA SDM contacts without details will not only avoid the STDLOG messages/errors, but prevent needless activity on the system.  Review your system to ensure that Notification rules are targeted to valid CA SDM contacts. 

 

Method #3 – Populate dummy data

Sometimes it is unavoidable that a CA SDM contact will be created without valid Notification details (Method #1). Further, a generic Notification rule will attempt to send a notification to these CA SDM contacts (Method #2).  The most common example where this may occur is with  “Group” Contacts.  It may be possible to populate dummy values in this case.

  • Notification Method – specify (or create) a value that you are not using, such as “SMS” or “Pager_Email” if all of your CA SDM Notifications use Email.

  • Email Address – specify a real, dummy email address. Ask your email administrator to construct an email address where everything is automatically destroyed after 24 hours. WARNING: Avoid specifying an invalid email address, otherwise you may receive other error messages/errors when the email fails.

 

Method #4 – Suppress log messages

You may suppress the messages that are written to the STDLOG and the Activity Log by adjusting certain internal settings. This creates a cleaner log file and maybe the only solution if you cannot employ Methods #1, #2 or #3 above.

Please review KB Article 117002 for further details about the given setting

Additional Information