Precheck Failed: vSphere HA agent cannot be installed or configured
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Article ID: 336391
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
Symptoms: Upgrade precheck fails with error: "vSphere HA agent for host <hostname> has an error in <cluster_name> in <workloadomain_name>. vSphere HA agent cannot be installed or configured."
Environment
VMware Cloud Foundation 3.x
Cause
This issue can occur when network traffic throughput between ESXi and vCenter Server is insufficient and the vCenter Server cannot push the FDM agent to the ESX host over the network in a timely manner.
Resolution
Run through the steps below to correct this:
Connect to the ESXi with SSH
Confirm that fdm isn't installed already :
esxcli software vib list |grep fdm
Connect to the vCenter Server Appliance using SSH.
Verify that you can ping the ESX host:
vmkping -I vmkx destination-ip
Verify that SSH is enabled on the ESXi host and that port 22 is not blocked:
Using WinSCP, SCP or a similar protocol, copy the fdm vib file located at /etc/vmware-vpx/docRoot/vSphere-HA-depot/vib20/vmware-fdm/ to the ESXi /tmp folder,
For Example: scp VMware_bootbank_vmware-fdm_6.0.0-3634794.vib root@ESXi_FQDN:/tmp
If the file fails to copy or takes a long time to copy to the host, insufficient network traffic throughput between ESXi and vCenter Server is preventing the agent from installing.