Migrating vCenter Server 6.7p05 to 7.0 version fails with error: Error downloading plug-in
search cancel

Migrating vCenter Server 6.7p05 to 7.0 version fails with error: Error downloading plug-in

book

Article ID: 336304

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
After migrating vCenter Server 6.7p05 to 7.0 version, the vSphere Client on 7.0 shows error similar to:
"Download plugin task fails with error: Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct."

Environment

VMware vCenter Server 7.0.x

Cause

With vSphere 6.7p05 release, VMware vSphere Update Manager Client is supported in vCenter Server for Windows by introducing new extension "com.vmware.vum.client".
When users migrate from 6.7 vCenter Server for Windows to 7.0GA, 7.0 U1, 7.0U2, this new extension will get exported to 7.x releases and UI will fail to load, causing error to show up in the vSphere Client.

Resolution

Steps to remove unwanted plug-in from the available plug-in list (In this case: "com.vmware.vum.client")
      
1. In a web browser, navigate to https://vCenter_Server_FQDN_or_IP/mob.
Where vCenter_Server_FQDN_or_IP/mob is the name of your vCenter Server or its IP address.
2. Log in with your vCenter SSO admin credentials.
3. Click content.
4. Click ExtensionManager.
5. Select and copy the key of the extension "com.vmware.vum.client" under Properties.
6. Click UnregisterExtension. A new window appears.
7. Paste the extension key com.vmware.vum.client (without quotes) and click Invoke Method.
   This removes the extension and results in void.
8. Close the window.
9. Refresh the Managed Object Type: ManagedObjectReference:ExtensionManager window to verify that the extension is removed successfully.