Connection failure errors encountered on Kubernetes apps when deployed as native vSphere pods
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Connection failure errors encountered on Kubernetes apps when deployed as native vSphere pods

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Article ID: 336303

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides information about the impact of some limits enforced on Kubernetes workloads by the Container Runtime (CRX) on Kubernetes applications when deployed as native vSphere pods.

Symptoms:
  • Kubernetes applications error when deployed as native vSphere pods in vSphere 7.0.
  • You see errors similar to:
“accept4() failed (24: Too many open files)” for some failed socket connections.


Environment

VMware vCenter Server 7.0.x

Cause

When deploying vSphere pods on a Supervisor Cluster, the Container Runtime Executive (CRX) on which the pods are deployed, has the following limits that might affect applications deployed in the pods:

Pending signals: 1601
Locked memory: 64 KB
Open files: 1024
Max user processes: 8192

The maximum open files limit will also restrict the number of network connections that can be opened by an application. Applications that hit these limits might fail to run or might run with reduced performance. Check the application logs for relevant error messages when encountering behavior that may be related to these limits.

Resolution

Currently, there is no resolution.

Workaround:
These limits have been increased in VMware vCenter 7.0.0B released in June 2020.