Logging in to VMware vCenter Server 6.0 with a domain user fails with the error: A server error occurred
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Logging in to VMware vCenter Server 6.0 with a domain user fails with the error: A server error occurred

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Article ID: 336226

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

When you attempt to log in to VMware vCenter Server 6.0 with a domain user, you experience these symptoms:
  • The VMware vSphere Web Client displays the error:
     

    A server error occurred.

    [400] An error occurred while processing the authentication response from the vCenter Single Sign-On server. Details: Status: urn:oasis:names:tc:SAML:2.0:status:Responder, sub status: null.

    Check the vSphere Web Client server logs for details.

  • The %ALLUSERSPROFILE%\VMWare\vCenterServer\logs\sso\vmware-sts-idmd.log file contains errors similar to:

    [YYYY-MM-DDT<time> vsphere.local c006bcab-####-####-####-########251 INFO ] [VmEventAppender] EventLog: source=[VMware Identity Server], tenant=[vsphere.local], eventid=[USER_NAME_PWD_AUTH_FAILED], level=[ERROR], category=[VMEVENT_CATEGORY_IDM], text=[Failed to authenticate principal [vcenter@domain]. Access denied], detailText=[com.vmware.identity.idm.IDMLoginException: Access denied
    </time>

Environment

VMware vCenter Server 6.0.x

Cause

This issue occurs when the domain in which the user you are attempting to log in does not exist as a VMware vCenter Single Sign-On identity source.

Resolution

To resolve this issue, add the domain as an identity source to vCenter Single Sign-On.
 
For more information, see the Add a vCenter Single Sign-On Identity Source section in the vSphere 6.0 Security Guide.

Additional Information