"Failed to match the SSL thumbprint for <vCenter_FQDN>." error while opening the VM console in vSphere Client
book
Article ID: 336160
calendar_today
Updated On:
Products
VMware vCenter Server
Issue/Introduction
You cannot open the console to a virtual machine using there VMware vSphere Web Client
Opening the console to a virtual machine using the VMware vSphere Web Client fails with the error:
Failed to match the SSL thumbprint for "vCenterServer_FQDN". Make sure that all security patches have been installed on the server and then retry the connection.
The VMware Client Integration Plug-in is installed
Environment
VMware vCenter Server 5.x
VMware vCenter Server 4.x
Cause
This issue occurs when the vimServiceVersions.xml file is corrupt or missing.
Resolution
To resolve this issue, verify that the C:\ProgramData\VMware\VMware VirtualCenter\docRoot\sdk\vimServiceVersions.xml file exists and the contents are valid.
To verify that the C:\ProgramData\VMware\VMware VirtualCenter\docRoot\sdk\vimServiceVersions.xml file exists and the contents are valid:
Log in as an administrative user to the machine running VMware vCenter Server.
Navigate to C:\ProgramData\VMware\VMware VirtualCenter\docRoot\sdk.
Verify that the vimServiceVersions.xml file exists.
If the vimServiceVersions.xml file does not exist, copy the file from another VMware vCenter Server running the same build.
If you do not have another VMware vCenter Server, use a text editor to create a new vimServiceVersions.xml file in C:\ProgramData\VMware\VMware VirtualCenter\docRoot\sdk with the contents: