Using the vSphere Client 5.5 to login, search, or sort the inventory fails with the error: Unable to connect to web services to execute query
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Article ID: 336147
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
Symptoms:
The search function fails.
Sorting the Inventory using vCenter Server fails.
Logging in to the vSphere Client fails.
You see errors similar to:
Unable to connect to web services to execute query. Verify that the 'VMware VirtualCenter ManagementWebservices' service is running on https://VC.FQDN.local:10443/
The viclient-0-0000.log file located at C:\Users\user_name\AppData\Local\VMware\vpx will display similar messages when vSphere Client login fails when using the Use Windows session Authentication:
yyyy-mm-ddT07:25:08.619-07:00 [03084 error 'httphttpUtil' opID=843CC5F5-000001A4-76] [HttpUtil::ExecuteRequest] Error in sending request - Operation timed out yyyy-mm-ddT07:25:08.619-07:00 [03084 error 'ServerAccess' opID=843CC5F5-000001A4-76] HTTP Exception while requesting remote proxy ticket: class Vim::Fault::HttpFault::Exception(vim.fault.HttpFault)
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Environment
VMware vCenter Server 5.5.x
Cause
This issue occurs if the user is part of a large number of Active Directory (AD) groups.
Resolution
This is a known issue affecting the vCenter Server 5.5 vSphere Client.
To work around this issue, use one of these options:
Use the vSphere Web Client. The Web Client is optimized for efficient group lookup and is recommended if you have a large AD environment.
Ensure that the user is not a member of a large number of Active Directory groups.
This is only applicable for AD over LDAP configuration:
Reduce the base DN scope:
For example:
Change dc=VMware, dc=com to dc=Admins, dc=VMware, dc=com
Use Global Catalog port 3268/3269 in the SSO configuration of AD over LDAP.
Note: Make sure Global Catalog port is enabled on domain controller.
Increase the timeout. To increase the timeout value using the vSphere Client:
Click Administration > vCenter Server Settings > Timeout Setting.