Auto Deploy rule management UI in vSphere Client is inaccessible with "Server has wrong SHA1 thumbprint"
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Article ID: 336063
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
"The Auto Deploy > Deploy Rules functionality in the vCenter UI is inaccessible, displaying the error: 'Managing rules is temporarily unavailable. Server has wrong SHA1 thumbprint (required) != (server)'."
Environment
VMware vCenter Server 6.x
VMware vCenter Server 7.x
VMware vCenter Server 8.x
Cause
This can happen when the vCenter machine SSL certificate was recently replaced, but Auto Deploy ( vmware-rbd-watchdog) still uses the old certificate thumbprint.
Resolution
Before proceeding with these steps, ensure a current backup or snapshot of the vCenter Server is established. If the vCenter Server is part of an Enhanced Linked Mode (ELM) configuration, it is imperative to capture offline snapshots of all associated ELM nodes."
To solve the issue, apply the following steps:
Open an SSH connection to the VC and login with root
Run sqlite3 against the Auto Deploy database:
# sqlite3 /var/lib/rbd/db
Run the following query to output the information about the VC from the DB, including current certificate thumbprint used by Auto Deploy:
select * from vc_servers;
Exit sqlite3 by running:
.quit
Now export the current machine SSL certificate from the vCenter Endpoint Certificate Store (VECS):