Dell Compellent vSphere API for Storage Awareness (VASA) storage provider does not appear in vCenter Server
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Dell Compellent vSphere API for Storage Awareness (VASA) storage provider does not appear in vCenter Server

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Article ID: 335961

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

If the Dell Compellent vSphere API for Storage Awareness (VASA) storage provider does not appear in vCenter Server, re-register the client plug-in to resolve the issue.

After upgrading from vCenter Server 5.x to 5.5.x, you experience these symptoms:

  • The Compellent vSphere API for Storage Awareness (VASA) storage provider does not appear in vCenter Server.
  • Adding the VASA storage provider back to vCenter Server fails.
  • You see the error:

    A problem was encountered while registering the provider.

Environment

VMware vCenter Server 5.5.x

Cause

This issue occurs due to mismatch in the certificates of vCenter Server and the Compellent VASA plug-in. When VASA storage provider is installed, it gets registered to vCenter Server along with its certificates. When vCenter Server is upgraded, certificates change and VASA plug-in does not work.

Resolution

To resolve this issue, re-register the client plug-in using the steps below:

  1. Unregister the client plug-in the Compellent Integration Tools for VMware (CITV) appliance.
  2. Delete files sms.keystore and sms.truststore from C:\ProgramData\VMware\VMware Virtual Center\SSL\.
  3. Reboot vCenter Server (not just the services). New certificates are now generated.
  4. Re-register the client plug-in in the CITV appliance.
  5. Restart the VASA provider in the CITV appliance.
  6. From the vSphere Web Client, register the storage provider again.

Additional Information