The CA Spectrum install stops due to User Access Control permissions issues UAC on Windows
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The CA Spectrum install stops due to User Access Control permissions issues UAC on Windows

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Article ID: 33593

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

During a CA Spectrum install on Windows, after the last configuration screen, a UAC error will show in the window noting you do not have proper permissions to run the install.

 
Errors occurred after providing account info with location to install software.
SPC-INT-20049  Insufficient Privileges on server to create registry entries.
SPC-INT-20050  Try using Administrator user for SRAdmin Authentication.

Environment

Spectrum install on Windows

Cause

The problem is even though you have disabled UAC from the User Account Control area, you have not actually disabled UAC until you edit the registry.

Resolution

Microsoft has created the following technical guideline to instruct users on how to actually disable UAC.  Once you have disabled UAC and rebooted, you will then be able to successfully run the CA Spectrum installation.

This document is for Windows 2012, but also applies to Windows 2016 and Windows 2019

http://social.technet.microsoft.com/wiki/contents/articles/13953.windows-server-2012-deactivating-uac.aspx  

 

Windows Server 2012: Deactivating UAC

Deactivating UAC in Windows 2008 R2 was possible via running msconfig (for example winkey+r -> msconfig), going to the Tools tab and launching "Change UAC settings".

There, you select "Never notify" to disable UAC.

The same approach is still available in Windows Server 2012, 20016, and 2019 though UAC is still active after you selected "Never notify".

Turn off UAC via registry by changing the DWORD "EnableLUA" from 1 to 0 in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system".

You will get a notification that a reboot is required. On some systems you do not need to reboot.  You can log out and log back in and the install will run.

Additional Information

If you look in the installation logs, you may see access is denied errors:

Failed to create key \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce: Access is denied.

Retrying request for \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\InstComps ...
Failed to create key \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce: Access is denied.

Retrying request for \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\InstComps ...
Failed to create key \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce: Access is denied.

 

ERROR: Must setup registry manually:
  Location: \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\Spectrum60\Environment
  Remove entry for \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\InstComps

Failed to create key \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce: Access is denied.

 

 

ERROR: Must setup registry manually:
  Location: \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\Spectrum60\Environment
  Remove entry for \HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\InstComps

Failed to create key \HKEY_LOCAL_MACHINE\Software: Access is denied.

 


Failed to create key \HKEY_LOCAL_MACHINE\Software: Access is denied.

ERROR: Must setup registry manually:
  Location: \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\Spectrum60\Environment
  Remove entry for \HKEY_LOCAL_MACHINE\Software\Cabletron

Removing x32 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\Spectrum52
Removing x64 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\Spectrum52
Removing x32 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\WebApps710
Removing x64 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\WebApps710
Removing x32 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\WebApps800
Removing x64 \HKEY_LOCAL_MACHINE\Software\Aprisma Management Technologies\WebApps800
Removing x32 \HKEY_CURRENT_USER\Software\Aprisma Management Technologies\Spectrum\ProcessD
Removing x64 \HKEY_CURRENT_USER\Software\Aprisma Management Technologies\Spectrum\ProcessD
ERROR: After many attempts, unable to update the Windows registry with all
       the necessary Spectrum environment variables!

** Error during Setting up Spectrum environment variables