Issue:
Starting the CA-CSM Tomcat proc fails with MSM0008E - System startup failed
uncategorized SQLException for SQL delete from component_fmid.; SQL state .HY000.; error
code .0.; ca.datacom.db.DBSQLException: ca.datacom.db.DBSQLException: NO ROW FOUND
Environment:
z/OS, Apache Tomcat, Datacom DB Server.
Cause:
With RO68630 and above a SELECT COUNT(*) FROM TABLE is not physically counting the rows in the table anymore but uses the row counter that is stored in the CXX .
The CA CSM application runs a DELETE FROM TABLE when the COUNT(*) returns a non-zero number .
In this case there were no rows in the table but the CXX row counter was not zero. CA CSM expects the DELETE to get a zero SQLCODE but since there were no rows the delete resulted in SQLCODE +100 with the DBSQLException.
Resolution:
Correct the CXX row count by running the RETIX with KEYID=*SETR.
Additional Information:
CA Datacom DBUTLTY Reference Guide for z/OS