"That Product component is not installed on that node." message received when trying to apply a patch on a Service Desk Manager server.

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Article ID: 33582

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Issue:

 On a 64-bit operating system I am using "APPLYPTF-64bit.exe" to attempt to apply a patch to a Service Desk Manager server. The patch process does not complete, and I receive an error:

"That Product component is not installed on that node."

 

Environment:

 This Issue is not dependent on any particular environment or Operating System.

 

Cause:

The version of ApplyPTF being used to apply the patch will not be based on whether or not the operating system is 32-bit or 64-bit. In this instance ApplyPTF fails to locate the Service Desk Manager install because Service Desk Manager is a 32-bit application.

 

Resolution:

Use a version of ApplyPTF that matches the version platform that the application is designed for. In this instance, since Service Desk Manager is a 32-bit application you must use the 32-bit instance of ApplyPTF to apply the patch. If you were patching a 64-bit application (for example, "Unified Self Service") you would use the 64-bit version of ApplyPTF.

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: