INIT ID ALREADY ACTIVE IN CCI error returned to SVCOMPR EOJ job
search cancel

INIT ID ALREADY ACTIVE IN CCI error returned to SVCOMPR EOJ job

book

Article ID: 33569

calendar_today

Updated On:

Products

Datacom DATACOM - AD Datacom/Server Datacom/DB Datacom/AD

Issue/Introduction

A batch SVCOMPR EOJ is executed to shut down a Datacom Server region, but the batch job fails because of the following CCI errors:

DSV00061E-Communications utility received CCI failure in function:CCIINIT
DSV00061E-RC = 8, DRC = 38
DSV00061E-Errortext = INIT ID ALREADY ACTIVE IN CCI

Environment

Release: 15.0
Component: Datacom Server

Cause

This problem usually occurs when several SVCOMPR jobs are executed concurrently and two of them use the same CCI ID.

Resolution

The failing SVCOMPR EOJ job can be resubmitted at a later time. An alternative way of shutting down the region could be issuing a EOJ console command (/F srvjname,EOJ) to the Datacom Server mainframe region (see section "Console Commands (SVCONPR)" of Datacom Tools documentation).

If the Datacom Server region is running with PROTOCOL=BOTH, TCP/IP can be used by SVCOMPR to communicate to the Datacom Server address space instead of CCI. HOSTNAME and PORT parameters must be added to the utility SYSIN. See section "Communication Utility (SVCOMPR)" of Datacom Tools documentation for details.

SVCOMPR SYSIN in case of EOJ via TCP/IP:

//SYSIN    DD *
APPLID=applid
HOSTNAME=hostname
PORT=pppp
EOJ
/*