[VMC on AWS] VR service is unavailable during site pairing with VMC after SRM is installed with HCX support
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[VMC on AWS] VR service is unavailable during site pairing with VMC after SRM is installed with HCX support

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Article ID: 335249

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Updated On:

Products

VMware Live Recovery VMware Cloud on AWS

Issue/Introduction

This article explains how to resolve VR issues if SRM is deployed with HCX flag.

Symptoms:
During the SRM VA deployment on-prem, you selected the HCX flag.
You are unable to select a VR appliance after successfully pairing on-prem SRM with VMC SRM.
You experience the following:
From on-prem site, VR services do not load under vCenter Server and services portion of the SRM pairing wizard.
From VMC site, when trying to create a protection group you receive error: Could not find VR server for VC.

Within the on-prem Support Bundle /Config/vmware-dr.xml file, you see the section:
<extension>
    <hmsKey>com.vmware.vcHcx</hmsKey>
    <hmsType>com.vmware.hcx</hmsType>
    <key>com.vmware.vcDr</key>
  </extension>

Cause

This is expected behaviour in SRM 8.3.
If you integrate Site Recovery Manager with HCX, you cannot use vSphere Replication in the same Site Recovery Manager instance.

Resolution

To resolve this, please follow the steps below:
  1. Disconnect the SRM pairing. No need to disconnect the VR pairing.
  2. Unregister the on-prem srm-va from vCenter and LookupService (from https://<your-srm-appliance>:5480)
  3. Delete the current on-prem srm-va.
  4. Provision and configure again new on-prem srm-va, but use HCX ovf property with value false.
  5. Connect the SRM pairing.


Additional Information

Deploy the Site Recovery Manager Virtual Appliance
https://docs.vmware.com/en/Site-Recovery-Manager/8.3/com.vmware.srm.install_config.doc/GUID-3FE5A617-AB08-4EE1-B9DD-EC1F227F304A.html