[VMC on AWS] VR service is unavailable during site pairing with VMC after SRM is installed with HCX support
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[VMC on AWS] VR service is unavailable during site pairing with VMC after SRM is installed with HCX support

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Article ID: 335249

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Updated On: 02-28-2025

Products

VMware Live Recovery VMware Cloud on AWS

Issue/Introduction

  • During the SRM VA deployment on-prem, the HCX flag is selected.
  • A VR appliance cannot be selected after successfully pairing on-prem SRM with VMC SRM.
  • The following is seen:
    • From the on-prem site, VR services do not load under vCenter Server and services portion of the SRM pairing wizard.
    • From the VMC site, when trying to create a protection group, this error is seen: Could not find VR server for VC.
  • Within the on-prem Support Bundle /Config/vmware-dr.xml file, this section is seen:

<extension>
    <hmsKey>com.vmware.vcHcx</hmsKey>
    <hmsType>com.vmware.hcx</hmsType>
    <key>com.vmware.vcDr</key>
  </extension>

Cause

This is expected behavior in SRM 8.3. When integrating Site Recovery Manager with HCX, it is not possible to use vSphere Replication in the same Site Recovery Manager instance.

Resolution

To resolve this, follow the steps below:

  1. Disconnect the SRM pairing. There is no need to disconnect the VR pairing.
  2. Unregister the on-prem srm-va from vCenter and LookupService (from https://<srm-appliance>:5480)
  3. Delete the current on-prem srm-va.
  4. Provision and configure again new on-prem srm-va, but use HCX ovf property with value false.
  5. Connect the SRM pairing.

Additional Information