When using vCenter Converter the converter agent fails to install with an error
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When using vCenter Converter the converter agent fails to install with an error

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Article ID: 335068

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • When converting a remote machine using vCenter Converter Standalone, you see the error:
Converter Standalone Agent installer/uninstaller failed on xxxxxxxxx.

Note: Where xxxxxxxx is the IP address or hostname of the source machine being converted.
  • When converting a remote machine using vCenter Converter, you see the error:
Unable to complete installation/uninstallation of vCenter Converter agent on xxxxxxxx
 
Where xxxxxxxx is the IP address or hostname of the source machine being converted.
  • In the C:\Documents and Settings\All Users\Application Data\VMware\VMware vCenter Converter Standalone\logs\vmware-converter-server-xx.log file ,you see entries similar to:
info 'App'] [agentManager,83] [AgentManager] Install Agent on xxxxxxxxx
info 'App'] [agentDeploymentWin32,47] [AgentDeployment] Connect to ADMIN$ on xxxxxxxxx as xxxxxxxxx\administrator
info 'App'] [,0] SMB manager: Error connecting to share [\\xxxxxxxxx\ADMIN$]: 1385
error 'App'] [agentDeployment,366] [AgentDeployment] Deployment on xxxxxxxxx failed: Unspecified error in remote execution mechanism
error 'App'] [agentDeployment,158] [AgentDeployment] Install of Agent failed on xxxxxxxxx
error 'App'] [agentManager,106] [AgentManager] Install Agent failed: converter.fault.AgentDeploymentFault


Environment

  • VMware vCenter Converter Standalone 4.0.x
  • VMware vCenter Converter Standalone 4.2.x
  • VMware vCenter Converter Standalone 5.0.x
  • VMware vCenter Converter Standalone 5.1.x
  • VMware vCenter Converter Standalone 5.5.x

Cause

This issue occurs when the vCenter Converter connection to the network share of the remote computer fails.

Resolution

Note: Ensure that there are no pending Windows updates on the machine and any anti-virus software is disabled during this process.
 
To resolve this issue, ensure that you can connect to the remote share.
 
To ensure that you can connect to the remote share:
  1. Ensure that you can access the shared location on the remote computer.
  2. Ensure that the Server service is running on the source machine:
     
    1. Click Start > Run, type services.msc, and click OK.
    2. Locate the Server service in the services console and ensure that the status is Started.
    3. If the service is not started, right-click on the service and click Start.
       
  3. Disable any firewalls, User Access Control (UAC), or Simple File sharing on the remote Windows guest operating system.

    For the list of necessary ports that are required to be open, see the vCenter Converter Administration Guide.
     
  4. Manually copy the Converter Agent Installer, VMware-Converter-Agent.exe located at C:\Program Files (x86)\VMware\VMware vCenter Converter Standalone, from the source computer to the remote computer and install the Converter agent.

If the preceding steps do not resolve the issue, install the vCenter Converter Standalone utility on the remote computer and start the conversion from the remote computer.

Note: Server service supports file, print, and named-pipe sharing over the network for the computer.

Additional Information