[VMC] Tanzu Deactivation Fails with "Cleanup requests to NSX Manager Failed"
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[VMC] Tanzu Deactivation Fails with "Cleanup requests to NSX Manager Failed"

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Article ID: 334976

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Updated On:

Products

VMware Cloud on AWS VMware Cloud on Dell EMC VMware vSphere 7.0 with Tanzu

Issue/Introduction

Detail one of the potential resolutions to this issue.

Symptoms:
Unable to deactivate VMC Tanzu on a specific SDDC. Tanzu results in a "Cleanup requests to NSX Manager failed."
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Cause

This can be caused by there still being either a workload VM or VM Template attached to one of the NSX-T Segments which Tanzu is attempting to cleanup at deactivation.

Resolution

  • Login to the Cloud vCenter as [email protected]
  • Select Networks tab
  • Select the Tanzu NSX-T Segment which is still shown. If there are multiple, repeat the process as many times as required.
    • Example segment naming would be "vnet-domain-c55:"
  • Click on the VMs tab
  • Ensure that no VMs are listed within this tab.
    • If some are, for each VM remove the vmnic attached to the specific Tanzu NSX-T Segment.
  • Click on the VM Templates tab
  • Ensure that no VM Templates are attached to this segment
    • If some are, for each VM Template first convert the template back to a VM, modify the VM by removing the offending vmnic, and then convert the VM back to a VM Template.

For example, check any deployed AVI Load Balancers as these are known to auto-attach to Tanzu Segments upon deployment.
 


Additional Information

Impact/Risks:
0