HTTP Failure Response observed on the HCX Transport Analytics tab
search cancel

HTTP Failure Response observed on the HCX Transport Analytics tab

book

Article ID: 334970

calendar_today

Updated On:

Products

VMware Cloud on AWS VMware Cloud on Dell EMC

Issue/Introduction

HTTP 500 failure is seen on the HCX Transport Analytics tab. Everything in HCX will continue to function (Site Pairs, Service Meshes, Appliance Tunnels, Migration, etc.) but you see this error in your OnPrem HCX plug-in.

You see this error on the HCX Transport Analytics tab when accessing the OnPrem HCX Plugin through vCenter (VC). Similar error will look like - "Http failure response for https://vcenter-name/ui/hcx/hcx-ui/rest/hybridity/api/ 500 OK"

Environment

VMware HCX

Cause

This issue appears to be an issue with the plug-in itself, as it can be confirmed you are not seeing the HTTP Failure Response error in either of the Cloud HCX Transport Analytics tab (Cloud VC HCX Plug-in & Cloud Manager GUI) and cannot see it in the OnPrem Connector GIU.

Resolution

Because the issue appears to be related to the OnPrem HCX Plug-in, the recommendation is to remove the plug-in and re-add it to the OnPrem vCenter.

To remove the plug-in from the OnPrem VC:

  1. Follow Step 2 in KB - Uninstall a deployment from Connector & Cloud.
  2. Complete every step to ensure the plug-in is removed successfully.
  3. To re-add the HCX Plug-in, reregister HCX with the OnPrem vCenter again.
  4. If after registering HCX with the OnPrem VC the Plug-in does not display, restart vsphere-ui within the OnPrem VC.

Workaround:

  1. Login directly to the OnPrem Connector GUI and observe the Transport Analytics tab.
  2. Additionally, you can observe the Transport Analytics tab directly from the Cloud Manager GUI or Cloud HCX Plug-in.

Additional Information

There is no impact to the HCX Service. All HCX functionality will continue to perform and this can just be seen in the OnPrem HCX Plug-in.