[HCX] HTTP Failure Response observed on the HCX Transport Analytics tab
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Article ID: 334970
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Updated On:
Products
VMware Cloud on AWSVMware Cloud on Dell EMC
Issue/Introduction
Customer may inbound with concerns around an HTTP 500 failure that is being seen on the HCX Transport Analytics tab. Everything in HCX will continue to function (Site Pairs, Service Meshes, Appliance Tunnels, Migration, etc.) but they will just be seeing this error in their OnPrem HCX plug-in.
Symptoms: Customer is seeing an HTTP Failure Response error on the HCX Transport Analytics tab when accessing the OnPrem HCX Plugin through vCenter (VC). Similar error will look like - "Http failure response for https://p-vcenter-102/ui/hcx/hcx-ui/rest/hybridity/api/ 500 OK"
Cause
This issue appears to be an issue with the plug-in itself, as it can be confirmed we are not seeing the HTTP Failure Response error in either of the Cloud HCX Transport Analytics tab (Cloud VC HCX Plug-in & Cloud Manager GUI) and cannot see it in the OnPrem Connector GIU.
Resolution
Because the issue appears to be related to the OnPrem HCX Plug-in, the recommendation is to remove the plug-in and re-add it to the OnPrem vCenter. To remove the plug-in from the OnPrem VC, please follow Step 2 in this KB - Uninstall HCX deployment from Connector & Cloud (74869) (vmware.com). Complete every step to ensure the plug-in is removed successfully. To re-add the HCX Plug-in, reregister HCX with the OnPrem vCenter again. If after registering HCX with the OnPrem VC the Plug-in does not display, restart vsphere-ui within the OnPrem VC.
Workaround: Login directly to the OnPrem Connector GUI and observe the Transport Analytics tab. Additionally, can observe the Transport Analytics tab directly from the Cloud Manager GUI or Cloud HCX Plug-in.
Additional Information
Impact/Risks: There is no impact to the HCX Service. All HCX functionality will continue to perform and this can just be seen in the OnPrem HCX Plug-in.