[VMC on AWS] Unable to connect to VMs sitting in a Network Segment after recently unextending the network from HCX.
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[VMC on AWS] Unable to connect to VMs sitting in a Network Segment after recently unextending the network from HCX.

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Article ID: 334967

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Updated On:

Products

VMware Cloud on AWS VMware Cloud on Dell EMC

Issue/Introduction

To help provide a resolution in getting the VMs network back up and running and able to connect between the customers AWS Native Account over the Transit Connect.

Symptoms:
Customer is attempting to reach their AWS Native account through the Transit Connect. Customer is unable to ping or see any traffic reaching their AWS TGW. Customer has encountered this issue after recently unextending the network from HCX.

Cause

HCX was not properly decommissioned causing the L2E segment to not be reprogrammed within VMC NSX properly.

Resolution

-Ensure HCX is completely cleaned up and undeployed from both OnPrem and VMC - Uninstall HCX deployment from Connector & Cloud (74869)
-Attempt to disconnect and then switch the segment back to routed

Workaround:
If attempting to disconnect and reconnect the segment does not work, we will need to create a new segment in VMC and migrate all the VMs to the new segment. Customer can quickly migrate VMs from one segment to another in the vCenter UI. Networking tab -> Select the old segment -> Migrate VMs to Another Network -> Proceed with the steps to select the VMs and the destination network.

Additional Information

Impact/Risks:
Customer is not able to ping or connect their VMs from VMC to their Native AWS account over the vTGW.