"A general system error occurred: Retrieve IPMI SEL request to host failed" alert on the vCenter
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"A general system error occurred: Retrieve IPMI SEL request to host failed" alert on the vCenter

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Article ID: 334938

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

The following alert will be received on an ESXi host.

"A general system error occurred: Retrieve IPMI SEL request to host failed"

/var/run/log/vmkernel.log will have entries similar to:

WARNING: ipmi: WriteStartPhase:217: ipmi: Timed out waiting for IBF to clear in write start phase.. Error: Timeout
WARNING: ipmi: SysIntKcs_ProcessRequest:577: ipmi: Failure in KCS write start phase. Error: Timeout
WARNING: ipmi: GetDeviceId:735: ipmi: Failed to process Get Device ID request. Error: Timeout
WARNING: ipmi: WriteStartPhase:217: ipmi: Timed out waiting for IBF to clear in write start phase.. Error: Timeout
WARNING: ipmi: SysIntKcs_ProcessRequest:577: ipmi: Failure in KCS write start phase. Error: Timeout
WARNING: ipmi: GetDeviceId:735: ipmi: Failed to process Get Device ID request. Error: Timeout
WARNING: ipmi: WriteStartPhase:217: ipmi: Timed out waiting for IBF to clear in write start phase.. Error: Timeout
WARNING: ipmi: SysIntKcs_ProcessRequest:577: ipmi: Failure in KCS write start phase. Error: Timeout
WARNING: ipmi: GetDeviceId:735: ipmi: Failed to process Get Device ID request. Error: Timeout
WARNING: ipmi: IpmiDriver_Init:208: ipmi: IPMI Device failed to respond to the GET DEVICE ID request. Error: Timeout
WARNING: ipmi: CreateIpmiDrivers:1256: ipmi: Failed to initialize IPMI driver. Error: Timeout
ipmi: No valid IPMI devices were discovered based upon PCI, ACPI or SMBIOS entries, attempting to discover IPMI devices at default locations

Environment

VMware vSphere ESXi 8.0

Cause

The message is due to the hosts IPMI system event log (SEL) filling up.

Resolution

There is no permanent resolution at this time.


Workaround:

Restart the vpxa agent on the host.

  1. SSH into the host with the root credentials.
  2. Run the following command

/etc/init.d/vpxa restart


Note: To clear the Host IPMI system event log (SEL), refer to this article - https://knowledge.broadcom.com/external/article?articleNumber=316579