Unmounting datastore fails with the error: HostStorageSystem.UnmountVmfsVolume" for object "storage_system" on vCenter Server "vCenter_server_name" failed
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Unmounting datastore fails with the error: HostStorageSystem.UnmountVmfsVolume" for object "storage_system" on vCenter Server "vCenter_server_name" failed

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Article ID: 334678

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides steps to resolve and work around the issue when unmounting a datastore fails with this HostStorageSystem.UnmountVmfsVolume" for object "storage_system" on vCenter Server "vCenter_server_name" failed
error.

Symptoms:
  • Un-mounting datastore fails.
  • In the vCenter Sever event log, you see an error similar to:

    Call "HostStorageSystem.UnmountVmfsVolume" for object "storage_system" on vCenter Server "vCenter_server_name" failed.
    Operation failed, diagnostics report: Cannot read the host cache configuration because some other process is modifying it at this time.

  • In the /var/log/vmkernel.log file, you see entries similar to:

    YYYY-MM-DD T TIME.814Z cpu5:26217015)WARNING: VisorFSRam: 305: Cannot extend visorfs file /tmp/bbFile2.txt because its ramdisk (tmp) is full.
    YYYY-MM-DD T TIME.835Z cpu5:26217018)WARNING: VisorFSRam: 305: Cannot extend visorfs file /tmp/bbFile2.txt because its ramdisk (tmp) is full.
    YYYY-MM-DD T TIME.839Z cpu22:35433)WARNING: VisorFSRam: 305: Cannot extend visorfs file /tmp/hp-bbUsg.txt because its ramdisk (tmp) is full.
    YYYY-MM-DD T TIME.094Z cpu22:32927)WARNING: VisorFSRam: 305: Cannot extend visorfs file /tmp/ql_ima.log because its ramdisk (tmp) is full.
    YYYY-MM-DD T TIME.094Z cpu22:32927)WARNING: VisorFSRam: 305: Cannot extend visorfs file /tmp/ql_ima_sdm.log because its ramdisk (tmp) is full.

  • TMP folder is 100 % filled up:
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.  


Environment

VMware vSphere ESXi 5.5

Cause

This issue occurs if the space on the ramdisk is insufficient.

Note: In this case, the /tmp folder is 100 % filled up.

Resolution

To resolve this issue, update the QLogic iSCSI drivers to version 634.55.28.0-1vmw, available at VMware downloads.

To work around the issue without updating the driver, delete unnecessary files to free up space on the ramdisk or reboot the ESXi host.

To delete unnecessary files on the ramdisk:
  1. Connect to the ESXi host using SSH.
  2. Run this command to display virtual filesystem usage:

    vdf -h

  3. Delete the unnecessary files to free up space on the ramdisk. It is safe to use the cd command to enter a directory in which you want to remove files and then use the rm command to remove unwanted files.
Alternatively, to work around this issue, reboot the host.

To reboot the host, use one of these options:
  • Log in to the ESXi host using SSH and run this command:

    reboot

  • Open the vSphere Client, select the host in the inventory panel, then click Power > Restart from the dropdown menu.