Hardware health status monitoring is unstable and not displayed
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Hardware health status monitoring is unstable and not displayed

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Article ID: 334461

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Hardware health status monitoring is unstable and not displayed.
  • Resetting the sensors and event log does not resolve the issue.
  • In the syslog.log, you see the entries similar to:
2017-12-03T20:30:37Z sfcb-vmware_base[1038465]: TIMEOUT DOING SHARED SOCKET RECV RESULT (1038465)
2017-12-03T20:30:37Z sfcb-vmware_base[1038465]: Timeout (or other socket error) waiting for response from provider
2017-12-03T20:30:37Z sfcb-vmware_base[1038465]: Header Id (380439) Request to provider 141 in process 5 failed. Error:Timeout (or other socket error) waiting for response from provider
2017-12-03T20:30:37Z sfcb-vmware_base[1038465]: Dropped response operation details -- nameSpace: root/cimv2, className: OMC_RawIpmiSensor, Type: 0

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vSphere ESXi 6.0

Cause

This issue occurs because the sfcb-vmware_base is waiting for response from other provider and crashing due to timeout.

Resolution

This is a known issue affecting VMware ESXi 6.0.

Currently, there is no resolution.

Workaround:
To work around this issue, increase the memory pool size for the process running out of memory.
  1. Stop the sfcbd service by running this command:

    /etc/init.d/sfcbd-watchdog stop
     
  2. Update the memory allocation by running this command:

    vsish -e set /sched/groups/<groupid>/memAllocationInMB minLimit=0 shares=1000 max=200

    Note: Provide the groupid of sfcb_aux and sfcb in the command.
     
  3. Start the sfcbd service by running this command:

    /etc/init.d/sfcbd-watchdog start

Note: This change is not persistent and the configuration will be back to default after host reboot.