Test Management Network from DCUI fails to resolve hostname in ESXi 5.1
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Test Management Network from DCUI fails to resolve hostname in ESXi 5.1

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Article ID: 334332

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
When using the Test Management Network function from the direct console user interface (DCUI), DNS name resolution fails. This is observed:
  • Tests that communicate through IP are working normally.
  • DNS resolves when pinging from other methods such as SSH.
  • Services that are configured to use DNS host names are working normally.
  • In the syslog.log file, this message is observed:

    DCUI: failed to restore /etc/hosts: boost::filesystem::rename: File exists: "/etc/hosts.backup", "/etc/hosts" "


Environment

VMware vSphere ESXi 5.1

Cause

This occurs because a temporary hosts.backup file is created in the /etc directory and is not automatically removed after the test is finished. Once this file exists in the /etc directory, all subsequent tests fail to resolve DNS names from the DCUI Test Management Network function.

Note: This impacts DNS resolution only in the DCUI. All other functions that require DNS name resolution on the host will function normally so long as a working DNS server is specified in the host's management network configuration.

Resolution

This is a known issue affecting ESXi 5.1.

To resolve this issue, move or delete the /etc/hosts.backup file to restore this functionality:
  1. Delete or rename the /etc/hosts.backup file:
    To remove, run the command: rm /etc/hosts.backup
    To rename, run the command: mv /etc/hosts.backup /etc/hosts.backup_old

  • Perform the Test Management Network operation from the DCUI again.

    Note: Testing again creates the /etc/hosts.backup file once again. Repeated operations from the DCUI fail until the file is manually deleted or removed again.


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