Error: "LINT1 motherboard interrupt" ESX/ESXi host fails with a purple screen of death
search cancel

Error: "LINT1 motherboard interrupt" ESX/ESXi host fails with a purple screen of death

book

Article ID: 333947

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • ESXi/ESX hosts experience instability or fail with a purple diagnostic screen citing an NMI, Non-Maskable, or LINT1 Interrupt.
     
  • The host console displays an error similar to the following:

    LINT1/NMI (motherboard nonmaskable interrupt), undiagnosed. This may be a hardware problem; please contact your hardware vendor.
     
  • A purple diagnostic screen may occur specifically when passing through a hardware device to a virtual machine, resulting in VMkernel core dump log events similar to:

    WARNING: IOMMUIntel: 2211: IOMMU Unit # 0: R/W = 1, Device 007:00.0 Faulting PA = 0xdf63e000 Fault Reason = 6

    Note: NMI log entries appear in the /var/log/vmkernel.log file, on the console, or in the VMkernel core dump file if the condition triggers a VMkernel purple diagnostic screen.

Environment

  • VMware ESXi 8.x

Cause

  • An NMI is a physical hardware event. It is typically the result of a non-recoverable condition (in the context of continued operation during that specific boot cycle) that the system BIOS and/or management chipset encounters.

  • NMI events are routed by the CPU through the Advanced Programmable Interrupt Controller (APIC) to the operating system (in this case, ESXi host) through the operating system kernel (in this case its VMkernel). 

  • An NMI event occurs due to hardware issues such as:

    • A PCI bus error, typically caused by a misbehaving I/O device or an electrical glitch.
    • A bad memory module or processor.
    • Severe thermal cycling of a critical component, usually after an extended downtime or a cooling component failure.
    • Components running out-of-specification, such as an over-voltage or under-voltage condition due to hardware fault involving a voltage regulator module.
    • Unapproved or incompatible components, such as an active memory backplane whose design revision is too early for the chassis.
    • A firmware, BIOS or other component mismatch. For example, such as option-card of revision X requiring a minimum option-card firmware revision Y and a minimum chassis BIOS revision Z.
    • On some systems, the CPU IOMMU feature that is used to map the DMA memory for a device from the host operating system to the guest operating system is configured by firmware to raise an NMI when it encounters an error, instead of allowing the operating system to catch and diagnose the error.  IOMMU errors are typically caused by misbehaving I/O device drivers or firmware.

Resolution

To troubleshoot and resolve an NMI event, perform the following steps:

  1. Isolate Virtual Machine triggers: Identify which Virtual Machines (if any) were powered on at the time of the NMI event. Check if powering on a specific Virtual Machine consistently triggers the crash.

  2. Inspect physical hardware: Reseat the physical PCI cards in the host, or attempt moving them to different PCIe slots to rule out a seating or slot issue.

  3. Contact your hardware vendor: Because an NMI is typically a hardware-level interrupt, you may need to engage your hardware vendor for further diagnosis. When opening a support case, ensure you provide the following diagnostic data:

    • The exact timeframe the event occurred.

    • At least 10 minutes of logs leading up to the event.

    • Chassis diagnostics log output and management chipset log output.

    • Chassis vital product data (VPD).

    • A complete vm-support log bundle from the affected ESXi/ESX host.

Notes:

  • Chassis management chipsets often function as an intelligent handler for chassis faults and can capture significant amounts of information during an NMI event.
  • The IBM xSeries chassis includes a BIOS option of Reboot on System NMI. When enabled, this results in an immediate chassis-reboot rather than a chassis-halt. In this event the ESXi host logs do not mention the NMI. Other enterprise hardware vendors may offer a similar BIOS option.

Additional Information