"You do not have the proper permissions to see this view. Contact your administrator" in Browse Details
search cancel

"You do not have the proper permissions to see this view. Contact your administrator" in Browse Details

book

Article ID: 333477

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction


Unable to view the"Browse Detail", "Containment" or "Notifications" Details relating to a device in the EMC M&R (Watch4net)  SMARTS Performance reports. Getting below error:



Environment

Watch4Net/M&R - 7.x
Smarts - 10.1.x

Cause

1). The data source of the details view is the underlying SMARTS (SAM) Service Assurance Manager. The error may occur if the logged in M&R (Watch4net) if user does not have the relevant permissions assigned to the underlying SMARTS SAM Server.

2). By default, the user "admin" in M&R is mapped to the admin-profile of the SMARTS SAM server at the time of Solution Pack installation. Any other M&R user must be mapped manually in order to gain permissions to the SMARTS SAM server.

Resolution

To map an M&R user to an SMARTS SAM user-profile, proceed as follows:

1). Go to the Administration EMC M&R (Watch4net) UI by Navigating to Administration > Roles and selecting the relevant Role for the required user(s) then Modules and Restrictions Access

2). Click on the Smarts parameter where you will be presented with a field to enter the relevant profile name as defined in the EMC SMARTS SAM Global Manager Administration Console. Please refer to the screenshot below:



3). Be sure to click "Save" when the change is complete.