Smarts events are cleared in Watch4net before they are cleared in Smarts
search cancel

Smarts events are cleared in Watch4net before they are cleared in Smarts

book

Article ID: 333047

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Smarts events begin to clear when the following error occurs within the Watch4net event-processing logs:

SEVERE - b::resync(): An error occurred while fetching active notifications from the SAM for <Listener name>. Some event might be missing....

After the above error, you can see within the processing logs the events being forcibly closed:

WARNING -- [2014-02-07 09:19:31 BRST] -- ActiveCacheDataStreamHandler$1::handle(): Forcibly close occurrence: com.watch4net.events.common.occurrence.GenericOccurrence
definitionKey=[Name=NOTIFICATION-BusinessProcess_BP__20088522_Sintetico (STRING)]

Environment

Watch4Net/M&R - 7.x

Cause

If the Watch4net resync job for Smarts Events cannot complete in time, Watch4net is configured to automatically clear events that are over one day old.  The default timeout for this job is set to 5 seconds, and in larger environments the Watch4net resync job can take two or three times longer to complete.

Resolution

The Watch4net/MnR resync job timeout can be increased to provide additional time for the job to complete before the automatic clearing of events occurs. This can be done within the active-cache.xml file as follows:
  • Make a backup copy of the active-cache.xml file found in <APG_BASE>/Event-Processing/Active-Cache/Default/conf/
  • In an XML editor, open the production active-cache.xml file and find the line:
    • <resync check-period="500ms" progress-timeout="5s" />
  • Increase the progress-timeout to 10s or 15s as shown in the following:
    • <resync check-period="500ms" progress-timeout="15s" />
  • Save and close the active-cache.xml file.
  • Restart the Watch4net Event-Processor to apply the changes in the active environment.