Customized reports that are saved are not accessible/disappear after logout/login
search cancel

Customized reports that are saved are not accessible/disappear after logout/login

book

Article ID: 332935

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Cannot access and run saved customized reports after logging out and logging back in to Watch4net

The following may be observed with this issue:
  • Can create, save and view Watch4net customized reports, but after logging out and logging back in, the reports are not available/seem to have disappeared
  • Unable to view Watch4net customized reports even though they were saved
  • Cannot see customized reports that were saved after logout/login to Watch4net
  • Tomcat server logs in Watch4net environment contain the following SEVERE messages at the time the customized report was created and saved:

    Caused by: java.sql.SQLException: Packet for query is too large (15485373 > 10485760). You can change this value on the server by setting the max_allowed_packet' variable.

     



Environment

Watch4Net/M&R 7.x

Cause

The SEVERE messages in the Tomcat logs mentioned above indicate that the report size is too large to be saved by Watch4net. The default size limit for a Watch4net report is defined as 10 MB (10485760, as mentioned in the above log error message example). In the above log example, the customized  report size  (15485373) exceeded this value, so the report could not be saved.

A customized report above the Watch4net maximum size limit can be created, loaded and viewed initially in Watch4net because the report is saved initially in the Front End Cache. However, if the report size exceeds the Watch4net maximum report size limit, it will never be pushed/saved to the APG database, and so will not persist through Watch4net logout/login. The following resolution explains how to adjust the maximum report size limit if you encounter this issue.

Resolution

To adjust/increase the maximum Watch4net report size limit, do the following:
  1. Navigate to the following directory in the Watch4net installation:
/opt/APG/Databases/MySQL/Default
  1. Open the my.cnf file for editing.
  2. Find the following line:
max_allowed_packet = 10M
(10 MB is default size)
  1. Change the max_allowed_packet value to the desired setting. The following setting example will allow a maximum report size of 20 MB:
max_allowed_packet = 20M
  1. Save and close the my.cnf file.
  2. Restart all Watch4net-related services.