SolutionPack for EMC Smarts has no Availability metrics or data for devices
search cancel

SolutionPack for EMC Smarts has no Availability metrics or data for devices

book

Article ID: 332908

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Watch4net SolutionPack for EMC Smarts has no data present or displayed in device Availability reports

Environment

VMware Smart Assurance - Watch4Net/M&R: 10.1.X

Cause

Availability in Watch4net is not a polled metric, it needs to be calculated by an availability filter. This issue occurs because there is no Availability filter installed and configured in the Watch4net emc-smarts collector-manager.

Resolution

If you encounter this issue, do the following:

  1. Install an Availability-Filter on the server where the emc-smarts Collector-Manager and Smarts-Collector are located. This can be done through the Watch4net Centralized Management interface or through the command line as follows:
    • Centralized Management:
      1. Go to SolutionPacks & Modules > Install.
      2. Select Collecting > Availability-Filter-vX.YuZ
      3. Click Launch.
      4. Set the instance name to emc-smarts.
      5. Click Install
    • Command line:
      • Run the following command:
/opt/APG/bin/manage-modules.sh install availability-filter emc-smart

 
  1. Using an XML editor, open the availability-filter.xml file found here:
/opt/APG/Collecting/Availability-Filter/emc-smarts/conf/availability-filter.xmlc
  1. Configure the Availability Filter calculation period in the availability-filter.xml file to match the Smarts-Collector's polling interval (which is 240 seconds by default):
<input name="Uptime" period="240" toleranceInSeconds="60" factorToSeconds="0.01" maxValueInSeconds="42949672.95" groupProperties="source" />
<!-- * name: the value of the up-time raw values 'name' property. -->
  1. Save and close the availability-filter.xml file.
  1. Using an XML editor, open the collecting.xml file found here:
/opt/APG/Collecting/Collector-Manager/emc-smarts/conf/collecting.xml
  1. Configure the Collector-Manager in the the collecting.xml file to use the Availability-Filter. To do this, add the following to the <filters></filters> section:
<filter enabled="true" name="AvailabilityFilter" next="<next element>" config="Availability-Filter/emc-smarts/conf/availability-filter.xml" />
  1. In the <collectors> </collectors> section, configure the Smarts collector to send data to the Availability Filter:
<collectors>
<collector enabled="true" name="emc-smarts" next="AvailabilityFilter" type="Sm-Discovery" config="Smarts-Collector/emc-smarts/conf/sm-discovery.xml" />
</collectors>
  1. Save and close the collecting.xml file.
  2. Restart the Collector-Manager in the Centralized Management interface or at the command line using the following command:
/opt/APG/bin/manage-modules.sh service restart collector-manager emc-smarts
  1. After a few polling cycles and when the property store has been refreshed, log out of the frontend interface.
  2. Log back in to the frontend interface and confirm that the SolutionPack for EMC Smarts Availability reports now have data present.