Incorrect availability value from the collector
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Incorrect availability value from the collector

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Article ID: 332860

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

  • The availability values from the Smarts collector is incorrect. This may also conflict with the reachability values. 
  • Incorrect availability value from the Smarts collector in Watch4Net/M&R
  • The following exceptions in the Smarts collector-manager log file may be encountered:
WARNING  -- [2012-09-25 00:13:41 EDT] -- AvailabilityFilter::pushData(): - last Uptime: 1348545124: other::I-SNMPAgent_Fault_MIB2-SNMPAgent-a_device-sysUpTime({devdesc=a_device_description, datagrp=SMARTS-PM, source=TEST-AM-PM-1, location=datacenter, name=Uptime, device=a_device_name, devtype=Node, contact=XXX, ip=x.x.x.x})=2.5472084E7

WARNING  -- [2012-09-25 00:13:41 EDT] -- AvailabilityFilter::pushData(): - new Uptime: 1348546324: group::I-SNMPAgent_Fault_MIB2-SNMPAgent-a_device-sysUpTime({devdesc=a_device_description, datagrp=SMARTS-PM, source=TEST-AM-PM-1, location=datacenter, name=Uptime, device=a_device_name,devtype=Node, contact=XXX , ip=x.x.x.x})=2.5582084E7



Environment

Watch4Net/M&R: 7.x

Cause

The availability filter to generates values from the "Uptime" raw values coming from Smarts and uses the "toleranceInSeconds" configuration to .

Example:

WARNING  -- [2012-09-25 00:13:41 EDT] -- AvailabilityFilter::pushData(): - last Uptime: 1348545124: other::I-SNMPAgent_Fault_MIB2-SNMPAgent-a_device-sysUpTime({devdesc=a_device_description, datagrp=SMARTS-PM, source=TEST-AM-PM-1, location=datacenter, name=Uptime, device=a_device_name, devtype=Node, contact=XXX, ip=x.x.x.x})=2.5472084E7

WARNING  -- [2012-09-25 00:13:41 EDT] -- AvailabilityFilter::pushData(): - new Uptime: 1348546324: group::I-SNMPAgent_Fault_MIB2-SNMPAgent-a_device-sysUpTime({devdesc=a_device_description, datagrp=SMARTS-PM, source=TEST-AM-PM-1, location=datacenter, name=Uptime, device=a_device_name,devtype=Node, contact=XXX , ip=x.x.x.x})=2.5582084E7

The calculation below is used to determine the "toleranceInSeconds":

  • 1348546324 - 1348545124 = 1200 seconds (where 1348545124 and 1348546324 are last "Uptime" and new "Uptime")
  • 2.5582084E7 - 2.5472084E7 = 110000 * 0.01 = 1100 seconds 
Hence, the "toleranceInSeconds" required for this polling is 1200 - 1100 = 100 seconds.

 

Resolution

When using the availability filter to generate availability raw value from "Uptime" raw values coming from Smarts, the "toleranceInSeconds" may need to be increased. To change this setting, review the instructions below:
  1. Log onto the collector host and edit the availability filter configuration file below:
Linux: /opt/APG/Collecting/Availability-Filter/emc-smarts/conf/availability-filter.xml
Windows: C:\Program Files\APG\Collecting\Availability-Filter\emc-smarts\conf\availability-filter.xml
  1. Find the "toleranceInSeconds" attribute in the "Uptime" entry:
<input name="Uptime" period="240" toleranceInSeconds="60" factorToSeconds="0.01" maxValueInSeconds="4294967295" groupProperties="source" />
        <!-- * name: the value of the up-time raw values 'name' property. -->
  1. Increase the value from the default 60 seconds to 120 seconds:
<input name="Uptime" period="240" toleranceInSeconds="120" factorToSeconds="0.01" maxValueInSeconds="4294967295" groupProperties="source" />
        <!-- * name: the value of the up-time raw values 'name' property. -->
  1. Save the changes and restart the Smarts collector. 

     


Additional Information

  • Increasing the value to match the polling period (240 seconds) or greater is not advised as this may cause the availability value to report incorrectly.