Running a test recovery / plan migration/reprotect fails with the error: There are not enough licenses installed to perform the operation
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Running a test recovery / plan migration/reprotect fails with the error: There are not enough licenses installed to perform the operation

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Article ID: 332643

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Running a test recovery / plan migration /reprotect fails with the below error.

    There are not enough licenses installed to perform the operation.

  • The licensing error is reported post SRM upgrade from 8.8 to 9.x.

    In vmware-dr.log, you will see the below events.
    2025-08-06T12:22:47.860Z error vmware-dr[05212] [SRM@6876 sub=Replication.VmRecoveryInterface ctxID=ef3b2662 opID=aacba5fe-d322-4d13-bd0d-2191a782d3a7-reprotect:8b67:ff81:75e5] Protection VM 'dr.replication.ProtectedVm:protected-vm-6095' failed operation 'Reprotect'!  There are '0' warnings for this Protection Group.  Failure Reason: (dr.fault.InsufficientLicensesFault) {

    -->    faultCause = (vmodl.MethodFault) null, 

    -->    faultMessage = <unset>

    -->    msg = ""

Environment

VMware Live Recovery 9.x

Cause

This issue occurs when a valid license is not assigned to the Site Recovery Manager (SRM) solution asset after an upgrade. SRM retains the license only during upgrades within the same major version. However, when upgrading across major versions—for example, from Site Recovery Manager 8.8.0.3 to 9.0—SRM reverts to an evaluation license, and the previously assigned license is not preserved. Refer the below kb for more details.

SRM License key missing after upgrading from SRM 8.x to SRM 9.X

 

Resolution

To resolve this, ensure the key is assigned to the Site Recovery Manager solution in vCenter Server for protecting the virtual machines on both production and disaster recovery site.

 
To assign the key to the Site Recovery Manager:
  1. In the vSphere Client, select Home > Administration > Licensing.
  2. Click the Assets tab.
  3. Click Solutions session.
  4. Identify and select the SRM extension.
  5. In the All-Actions Menu, select Assign License.
  6. In the Assign License window, select an appropriate license key and click Next.
 
Note: If you are reprotecting your virtual machine, ensure that preceding steps are done for both Protected and Recovery vCenter Servers.