ITCM Report when opened with Excel is not correctly displayed

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Article ID: 33244

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

When opening the report with excel, the column are not organized.

Cause

When requesting itcm report to be opened with excel the result is not displayed by columns
Steps used causing the issue:
 
open the ITCM reporter, go to the results to export, right click on the results and select "open with / Excel desktop (CSV file)"
here next the screenshot with the results, only one column with all the entries is displayed at the left side
 

Environment

Client Automation - Any Versions.

Resolution

With the ITCM r12.9 and 14.0 a new entry is provided in the policy, go to 
 
configuration policy / <Your Default Computer Policy> / DSM / Administration console
 
here there is a new entry "CSV Export Data Format", by default it is set to "Unicode"
 
Unseal the policy and change it to "ANSI", seal the policy and verify that the manager have been updated with the changes.
 
you can issue the next command to verify the results it will be "unicode" or "ANSI"
ccnfcmda -cmd getparametervalue -ps /itrm/adminconsole -pn csvexportdataformat 
 
 
Close and open the Report Explorer and proceed again with the same steps:
right click on the results and select "open with / Excel desktop (CSV files) "
now the excel is displayed with the results by column, here next the screenshot with the results

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