Keyboard or mouse do not work in a Windows virtual machine after P2V
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Keyboard or mouse do not work in a Windows virtual machine after P2V

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Article ID: 332355

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Updated On:

Products

VMware Desktop Hypervisor

Issue/Introduction

Symptoms:

  • The keyboard or mouse does not function within a Windows virtual machine
  • Either the mouse or keyboard showing Error Code 10 in Windows Device Manager
  • This device cannot start. (Code 10)
  • Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)



Cause

The Error Code 10 is generated when the Windows device manager has insufficient information. Windows and 3rd party keyboard drivers add filter drivers to enhance mouse and keyboard functionality which might not work correctly.

Resolution

To solve the issue, modify the filter values as given below.

Note: This procedure modifies the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft article 136393.

Also, recommend taking snapshot of the VM before proceeding.

Keyboard:

  1. Open On Screen Keyboard
  2. Click on Start > Run
  3. Type regedit and click on OK
  4. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
  5. Select the Key {4D36E96B-E325-11CE-BFC1-08002BE10318}
  6. Right click on UpperFilters and select Modify
  7. Delete anything in the Value Data and type kbdclass (Without quotes and all in small case)
  8. Reboot the Virtual Machine


Mouse:

  1. Open Start > Run
  2. Type regedit and click on OK
  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
  4. Select the Key {4D36E96B-E325-11CE-BFC1-08002BE10318} or {4D36E96F-E325-11CE-BFC1-08002BE10318}
  5. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
  6. Right click on UpperFilters and select Modify
  7. Delete anything in the Value Data and type mouclass (Without quotes and all in small case)
  8. Reboot the Virtual Machine




Workaround:

Below steps can be tried when customer has no mouse and keyboard access on the Guest Operating System in VMware Fusion and VMware Workstation Pro.

These steps will only work if customer has already enabled Remote Desktop option before converting the PC. Windows Operating System keeps Remote Desktop option turned off by default.

1. Shut down the virtual machine.
2. Add a new 'Host Only' Network Adapter to the virtual machine.
3. Open 'Terminal' from /Application/Utilities on Mac host or 'Command Prompt' in Windows host.
4. Use command ifconfig/ipconfig on Mac/linux and Windows host
5. Note the 'vmnet1' IP Address.
6. Download and install any Remote Desktop tool.
7. Use the vmnet1 IP Address with last octet modified with 128 to initiate the RDP to the virtual machine.

For example : If vmnet1 IP Address is 192.168.1.15, use this IP Address while taking the Remote Desktop session: 192.168.1.128

You may then follow the steps suggested in the article to troubleshoot the issue.