Login to domain manager failed | Permission denied error.
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Login to domain manager failed | Permission denied error.

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Article ID: 332271

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

  • Error in connecting to domain manager due to permission denied error.

  • Session disconnected alert between domain manager and global manager due to permission denied error in SAM logs. 

  • Unable to run Smarts IP sm_tpmgr command to load seed file

  • Running the following sm_tpmgr command in Smarts IP: 

sudo /opt/InCharge/IP/smarts/bin/sm_tpmgr -s <Domain> --seed=/opt/InCharge/IP/smarts/local/script/discovery/seedfile3 | tee

  • Results in the following ASL error: 

ASL-E-ERROR_INIT_BACKEND-While initializing server connection to 'IP Domain' SM-ELOGIN-Login to Domain Manager failed; permission denied; in file "/work/tancurrent/DMT-9.1.0.0/42/smarts/skclient/servif/SM_Broker.c" at line 420

Environment

SMARTS-10.1.x

Cause

The Smarts IP ServerConnect.conf  file does not have the same admin password as the clientConnectconf file.

Resolution

To address this issue, do the following:

  1. Using sm_edit, edit the admin user password in both the clientConnect.conf and ServerConnect.conf configuration files to make sure that the admin password matches in each file.
  2. Save and close the updated file.
  3. Upon saving, Smarts will create/update the file in the Smarts local/conf folder, and the password will be encrypted as required.