Smarts IP: Switch trunk port is not detected as a trunk port after discovery; Switch Port is discovered with port type of ACCESS rather than TRUNK
search cancel

Smarts IP: Switch trunk port is not detected as a trunk port after discovery; Switch Port is discovered with port type of ACCESS rather than TRUNK

book

Article ID: 332243

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




User reported a switch port that had been defined as a TRUNK in the port's configuration. However when the switch is discovered, the port shows a port type of ACCESS rather than TRUNK. This is causing issues since ACCESS ports are not managed by default and the port does not generate alarms even when it goes down.


Environment

VMware Smart Assurance - SMARTS

Cause

Smarts discovery does not use the device configuration to determine a trunk port. It uses the bridging information from both sides of the connection to determine if a port should be marked as a trunk port or not.
 
In this case, only one of the two devices with the trunk port was managed in Smarts. As Smarts needs information from both devices, the port is not detected as a trunk port.

Resolution

There are two options, the best solution would be:
 
1- discover both devices into Smarts and allow the discovery process to determine that this is a trunk port.
 
If it is not possible for the other device to be detected. 
 
2- explicitly manage the port. It will still not be detected as a trunk port, but it will allow Smarts to report notifications if the port goes down.