Smarts SAM: Increment in Count for notification does not trigger Escalation policy for create/Update ticket
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Smarts SAM: Increment in Count for notification does not trigger Escalation policy for create/Update ticket

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Article ID: 332241

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Increment in count for notification does not trigger Escalation policy for create/Update ticket.  It is observed that the escalation policy gets triggered when the notification comes in for first time.  When the notification comes in multiple times without the original alert clearing the alarm count gets incremented but the escalation policy of create/update does not get invoked.

Environment

VMware Smart Assurance - SMARTS

Cause

Escalation policy is configured to run on the first notify for the notification but cannot execute against multiple notifies that increment the count statement because combining the filters for a first notify and for multiple subsequent notifies will result in logic condition that only can be true on the first notify.

Resolution

A solution to resolve this issue is to create two paths in the escalation policy with the Count property applied to the filter
 
  • The filter on the first path has count = 1 and will trigger on the first occurrence.
  • The filter on the second path has count range <2-1000> and will trigger on each of the other occurrences.
Another  solution to resolve this issue is to create an escalation policy where the filter has two pages (tabs denoted by OR) with the Count property applied to the filter :
  • The filter on the first page has Count == 1 and the will cause the escalation policy to trigger on the first occurrence.
  • The filter on the second page has Count == <2-xxx> and will trigger on each of the subsequent notifications up to xxx renotifications.  XXX needs to be defined.