Smarts SAM: Webconsole does not display notifications; Web Console blanks screen
search cancel

Smarts SAM: Webconsole does not display notifications; Web Console blanks screen

book

Article ID: 332232

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




User has a huge number of notifications in their SAM domain (~60k).

The user can open the SAM Console (thick client) and view these notifications after a small delay processing the notifications.

However, when the user opens the Smarts SAM Web Console(thin client), the notifications will not show. The screen remains blank after the message which says:

Processed xxxx Notifications

Environment

VMware Smart Assurance - SMARTS

Cause

Java is running out of memory, thus it is unable to load all of the notifications from SAM in the webconsole.

Resolution

Please add the following parameter  -Xmx1024M to the JRE Settings on the Windows machine running the thin client.

Proceed as follows:

Start -> Control Panel -> Java -> Java Tab -> Click View button.

In the User tab for the 1.7 platform, click on the Runtime Parameters field to add the following:

-Xmx1024M



Then click ok, close whichever browser you were using then re-open it and try loading the webconsole again.